3

When a admin user sets a contributors record on civicrm/contribute?reset=1 from pending to completed an email is sent out.

Is it possible to turn off this email function for this email only.

2

You mean the receipt?

There is a checkbox "Send Receipt?" when you modify an individual contributione. If you uncheck it, it shouldn't send the email.

1

As Xavier says you need to uncheck the Send Receipt? box. If you want the box to be unchecked by default, you could create an extension or use an existing one, as explained here, and implement the hook_civicrm_buildForm to set the is_email_receipt value to false:

function myextension_civicrm_buildForm( $formName, &$form ) {
  if ("CRM_Contribute_Form_Contribution" == $formName) {
    $defaults = array ("is_email_receipt" => false);
    $form->setDefaults($defaults);
  }
}

I've added the example extension on github here, feel free to use it.

0

You can use DO NOT EMAIL flag for the contact for whom you don't want to send the email just before updating the status of the contribution.

You can find this in-

  1. Open Edit Contact Summary page for the contact civicrm/contact/add?reset=1&action=update&cid=<contact_id>
  2. Expand Communication Preferences tab.
  3. Enable Do Not Email checkbox in the Privacy section.

Save this contact. Do remember to turn this flag off after completing your status update. Thx!

2
  • 1
    I think the question clearly is asking how to stop just the email that goes out from updating the status of the contribution. Your suggestion does not specifically address that unless you are suggesting that the set it to 'do not mail' change the contribution status, and then set it back.
    – petednz - fuzion
    Oct 16 '15 at 20:16
  • updated the answer. Thx! Oct 19 '15 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.