I seem to be having a problem that a number of people are running into that I'm hoping we can solve. When I sent out emails using the "track click through" enabled, I end up with URLs that direct to white screens.

What should direct to http://www.mysite.com/contribute/

instead directs to this url, which gives a white screen.


We're running Wordpress 4.3.1 CiviCRM 4.6.6

thoughts? suggestions? Would it help to post the actual site urls? Needless to say as this is a fundraising email, I've got a development director in the other room melting down over this, so any help would be greatly appreciated. Thanks!

  • A development director with melt down... I know the feeling, and you have my sympathy! Hopefully someone could give you a tip during the weekend:-)
    – Flying
    Commented Oct 16, 2015 at 19:02
  • I don't use WP much but demo shows the link you should be putting in should be like wp46.demo.civicrm.org/civicrm?page=CiviCRM&q=civicrm/…
    – petednz - fuzion
    Commented Oct 16, 2015 at 20:22
  • I assume you are using some WP redirect that is setting /contribute to 'something else'. Can you check what you have entered there and report back.
    – petednz - fuzion
    Commented Oct 16, 2015 at 20:23
  • -petednz No, the link is right. Works just fine on the site. And no WP redirect (It's just CiviCRM contribution in a WP page). The "track click through" just gives that weird link to the white screen of death and I can't seem to figure it out. Also of note, if I turn off the "track click throughs" in an email I send out, the links work just fine.
    – Devin
    Commented Oct 16, 2015 at 20:48

1 Answer 1


Devin, your description is eerily similar to a problem I had on our Drupal site. Without track click through, things were fine. Once those were enabled, no dice.

For our situation (CiviMail - when Track Click Throughs is enabled, links result in a white screen with warnings), it turns out it was due to a PHP setting issue. Jon G's answer explains the why. Richard's answer explains how we fixed it.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.