4

I used to have Logging functionnality activated on one of my civicrm instance but when i look at log_civicrm_address, nothing seems to be logged since quite a while.

When i look at the config screen Administer -> System settings -> Misc (Undelete, PDFs, Limits, Logging, Captcha, etc.), the logging functionnality is disabled and neither set to Yes or No.

enter image description here

How can i re-enable this (and any idea why it's like that) ?

EDIT

CiviCRM is in version 4.6.5 and logging was activated in 4.2 (or maybe before).

1

I don't have an idea why it got turned off; perhaps an upgrade cleared it?

At any rate, a fresh install does not set a default selection on these radio buttons. You should be able to simply select Yes and then save.

  • Thanks, but there is no way in the UI to do so as shown in the screenshot i've just added – samuelsov Oct 20 '15 at 14:30
  • 1
    Ah, the picture helps! So the logging question is completely disabled. It does appear that upgrades to CiviCRM do disable logging when an upgrade is done, and should then reenable them upon completion of the upgrade. I am wondering if one of your upgrades never fully completed. – DaveD - BackOffice Thinking Oct 20 '15 at 14:33
  • 1
    I would recommend running the CiviCRM upgrade script to see if it resets things correctly. For Drupal: /?q=civicrm/upgrade&reset=1 – DaveD - BackOffice Thinking Oct 20 '15 at 14:46
  • I think it might be checking that you have permissions on the DB before it lets you enable? (Assuming the upgrade is showing as cleanly completed) – Parvez Saleh Oct 20 '15 at 14:47
  • 1
    We've had a quick look at the code behind the radio option and its checking if the database user has Trigger permissions on the database. My suspicion is that you don't have that permission on this particular database. It may be that you've moved it to test the upgrade or something hence not all permissions as they should be. – Parvez Saleh Oct 20 '15 at 16:17
1

Finally, i have found out that the disabling of Logging is caused by one of two things :

  • Trigger permissions is not available on your instance (thanks Parvez for spotting that)
  • You are in a multilingual configuration

In my cases, all our sites are multilingual so that's why i can't add the logging functionnality. For the site i was asking, the site was first monolingual and became multilingual which explain why i have been able to enable it and why i can't anymore.

I guess the multilingual triggers don't play nicely with logging triggers.

0

We use the logging functions for most of our clients. Really depends on what version of CiviCRM your on as to what the problem might be so if you could share that I may be able to point you in the right direction.

Also theres no danger in trying to turn it back on, it wont drop the old logging tables, it'll check for their existence prior to doing anything. If they exist then triggers will simply be added to the base CiviCRM tables.

  • Just added the version of CiviCRM in the post – samuelsov Oct 20 '15 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.