1

I'm running the security pro plugin, created by iThemes, as I do with many of my wordpress sites. One of my many security steps I run through is "Hide Login Area" however once changing the standard wp-admin directory it seems my CiviCRM plugin has difficulties processing secure SSL forms due to that plugin wanting to access the now non-existent "wp-admin" connection.

It comes to a not_found page and only started happening after the ssl certificate loaded and civicrm told to redirect contributions pages to ssl.

Is there a way to work around this in CiviCRM?

1

Check the URL set in CIVICRM_UF_BASEURL in your civicrm.settings.php matches the updated location of your site.

Protocol may now be https:// instead of http:// - I'm not familiar with Security Pro plugin; it may need to be improved to account for CiviCRM URLs also.

There's no harm in making the entire site SSL, which keeps configuration simpler ... just redirect all HTTP traffic to the encrypted URL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.