I just tried to export all my contact info from MailChimp. Basically, it worked and I am now the happy owner of a pretty CSV file... but all the data is saved in only one column, one row per contact.

For example, my data is stored as

[email protected],Axel,Grunt,"Lieber Herr Grunt",,J,J,J,,,"Zukunft statt Autobahn",,,,"Deciders only, Deciders auch","progressive GroßspenderInnen",Newslettertest,,,html,5,,,"2012-09-13 19:32:42",,48.2092000,16.3728000,1,2,Europe/Budapest,AT,9,"2013-10-28 08:14:49",26171677,963968a07a,

When I want to import the data on CiviCRM, it can't read the data but thinks it would be a terrifying misspelled email address.

Any solution?

2 Answers 2


If you are working with Microsoft Excel 2000 or later, you can use the following steps.

Select the "Data" tab. You should see an option that say "Text to columns". Highlight your column and choose that. A little window should pop up to walk you though, but you'll want to choose "Delimited" (next) and that your separator is a comma. When you click finish, this will put the data between each comma into a new cell.

  • You forgot to add the program name (Microsoft Excel 2000 or later). Not everyone use Excel and some may use only text editor (e.g. Notepad++), which this answer doesn't apply.
    – Andrew T.
    Oct 20, 2015 at 9:39

Your file seems to be a valid csv file with a comma separator. It should be readable by CiviCRM but you have to ensure you tell CiviCRM about :

  1. the separator, see the field "Import Field Separator" in the Contact Import page or change it globally in Administration -> Settings -> Languages, Currency, Location or civicrm/admin/setting/localization?reset=1
  2. the encoding if it's not UTF-8, see the page Administration -> Settings -> Languages, Currency, Location or civicrm/admin/setting/localization?reset=1

If you want to read and edit this file using a Spreadsheet, you can follow Heather O. suggestion for MsExcel or use LibreOffice/OpenOffice which should be able to autodetect the csv file configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.