2

Since upgrading to CiviCRM 4.6.9 on Drupal 6.37, when using track click throughs in CiviMail, links send to Page Not Found.

2 Answers 2

2

What is the url to track that generates the page not found?

One common problem is that your apache/nginx rules are wrongly redirecting the url used to track the clicks to be handled by drupal

Is this a "real" 404 page (coming from your webserver) or is this drupal handling that page and generating a page not found?

4
  • All of the links in the email send readers to Page Not Found, unless Tracking is turned off. This didn't happen before upgrading to 4.6.9, so I suspect the problem is more Civi based than Drupal or Apache based.
    – Suzanne
    Oct 24, 2015 at 17:08
  • All the links in the email send readers to Page Not Found at (mysite/sites/default/modules/civicrm/extern/…), unless Tracking is turned off.
    – Suzanne
    Oct 24, 2015 at 17:17
  • and where did you install your civicrm? into sites/default/modules or into sites/all/modules (the later is the common way)
    – Xavier
    Oct 25, 2015 at 13:22
  • sites/default/modules
    – Suzanne
    Oct 26, 2015 at 18:09
0

I thought this patch fixed the problem: https://issues.civicrm.org/jira/browse/CRM-7400

But, I spoke too soon. Still having the same "Page Not Found" issue when Tracking Click Throughs is turned on.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.