Wordpress 4.3.1

CiviCRM 4.5.5

Old host: Apache 2.2.26 - PHP: 5.3.28 - MySQL: 5.1.73

New host: Apache 2.2.29 - PHP: 5.3.29 - MySQL: 5.6.23

My only export options on the old host are via phpMyAdmin or cpanel export on the old host. I basically get a data.sql.gz file.

When I do this in ssh on the new host:

mysql -u username -p -h localhost DATA-BASE-NAME < data.sql

I'm getting this error:

ERROR 1881 (HY000) at line 48: Operation not allowed when innodb_forced_recovery > 0.

What can I do with my sql file or from the old host's phpMyAdmin so that the data import properly into the new host?

  • Could you provide the SQL statement at line 48 of the file?
    – Joe Murray
    Oct 23, 2015 at 17:47
  • Thanks for your reply. The line is too long for this venue. (5698 characters) It starts: INSERT INTO civicrm_acl` (id, name, deny, entity_table, entity_id, operation, object_table, object_id, acl_table, acl_id, is_active) VALUES (1,'Edit All Contacts',0,'civicrm_acl_role',1,'Edit','civicrm_saved_search',0,NULL,NULL,1),` and ends ,(65,'Core ACL',0,'civicrm_acl_role',2,'All','view event info',NULL,NULL,NULL,1);
    – Chris
    Oct 23, 2015 at 20:50
  • Line 47: /*!40000 ALTER TABLE civicrm_acl` DISABLE KEYS */;` Line 49: /*!40000 ALTER TABLE civicrm_acl` ENABLE KEYS */;`
    – Chris
    Oct 23, 2015 at 20:55

1 Answer 1


It appears from this other StackExchange answer that the MySQL on the new server may be set to read only. Try opening the my.cnf configuration file for MySQL and changing the setting.

  • Thanks, Joe Murray. Apparently a setting of innodb_force_recovery = 1 in /etc/my.cnf causes tables that are innodb format to be read only. I'm trying to get the hosting box owner to change it. Please stand by.
    – Chris
    Oct 28, 2015 at 3:23
  • PS If a StackExchange answer addresses your question/problem, then it is good form to check it as accepted, and to up-vote it. But I get it that you don't yet know if this will solve the issue.
    – Joe Murray
    Oct 29, 2015 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.