2

I am running CiviCRM 4.6.8 on Wordpress 4.3.1. I have configured my hosting providers SMTP details (as provided by them) under outbound email settings and when I click on "Save & Send Test Email", the email is sent successfully.

When I compose a new mailing under Mailing -> New Mailing, and click on the "Send Test" button to send a test email to myself, I get this error:

Error in call to Mailing_send_test : Failed to set sender: b.167.72.4a390771944bc4a6@ [SMTP: Invalid response code received from SMTP server while sending email. This is often caused by a misconfiguration in Outbound Email settings. Please verify the settings at Administer CiviCRM >> Global Settings >> Outbound Email (SMTP). (code: 501, response: : domain missing or malformed)]

What is the problem here and how do I resolve it?

3

This is a problem not with your SMTP but with your Mail Accounts settings in CiviCRM. When using CiviMail (as opposed to other emails from CiviCRM), the headers are altered so that the message comes from a unique address. If a message bounces, CiviCRM can know exactly which recipient of which message generated the bounce.

The unique address is generated from the account in Administer - CiviMail - Mail Accounts selecter for bounce processing. It's made up of the Localpart (if set), a "b" followed by random string of numbers and dots, an "@" sign, and the Email Domain.

Looking at the address shown in your error message, it's missing the domain, and that's what the error is complaining about. Check your Mail Accounts settings to be sure you have the domain set.

Incidentally, while you're at it, you should double-check the whole bounce handling system:

  1. Mail to random addresses at the domain you set should end up in a single mailbox.

  2. Your IMAP or POP settings in Mail Accounts should work for checking that mailbox.

  3. Your scheduled job for fetching bounces should be running.

See the page on book.civicrm.org for more information.

  • Hi, I found that I had not setup an email for bounce processing and configured the mailer properties to set the batch limit as my hosting provider only allows 800 emails per hour. I also needed to configure a cron job for bounce processing in C-panel. I did a test and sent a scheduled email to test group and it worked fine. I am now doing more testing with various FROM emails addresses that I have configured. – Sudesh Oct 25 '15 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.