3

What is the easiest way to get a 4.0 version of CiviCRM up to date or at least to a secure version? Is it possible to import a MySQL dump from 4.0 version into a new clean 4.7 version?

3

Easiest thing to do is upgrade in stages, go from 4.0 to 4.1, then to 4.2 then you can try straight up to 4.6

This approach should mean you dont hit too many issues

2

At minimum you would need to upgrade to 4.4 - this is the current LTS version and is the oldest version which still receives security patches.

As Parvez recommended, upgrading in stages is sometimes smoother, although 4 versions is not such a big jump that you can't necessarily do it all at once. Always back up your database first, and if jumping straight from 4.0 -> 4.4 doesn't work perfectly, try 4.0 -> 4.2 -> 4.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.