0

I have about 4,500 rows of participant that I would like to import. In each row is a column for the CiviCRM internal ID and columns for the requisite information about the event.

When I upload the CSV file about 400 rows are imported and for each of the other rows I get this error "Matching Participant record not found for Participant ID 10180. Row was skipped." Of course the ID number changes for each row.

I have cross-checked several rows and the IDs are valid.

The file is a CSV file so Excel formatting should not make a difference but I tried changing the field format and a few other things in Excel. Nothing has worked.

There are many duplicates in the list but not 4,000. I have the duplicate setting set to update.

I appreciate any help.

1

I re-ran the import with skip for duplicates and it worked perfectly. For my case this fixed the problem.

-Josh

0

After an import the failed rows are included in a new CSV file which you could download. That file contains the errors and per row why it failed.

It could be basicly something as invalid e-mail address e.g.

  • The error is "Matching Participant record not found for Participant ID 10180. Row was skipped." The 10180 is changed for each of the CiviCRM ID's. I am sorry if I was not clear with this. – Josh Nov 5 '15 at 13:34
  • The error is caused because you on duplicate setting set to update. Your participant id column should not contain the civicrm contact id but the participant id. – Jaap Jansma - CiviCooP Nov 5 '15 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.