1

I'm running a monthly activity import into a site (4.4.13) [I realise it's due an upgrade to LTS]

We have a standard csv tempalte, and existing field mapping. And have been using the same method consistently for over 12 months.

Today on running the first batch all were rejected with the error message "source_contact_id is not valid : 2"

The source contact field is not included in the import csv and has previously been automatically picked up from logged in user id ("2").

User 2 is the site admin account and has full permissions.

The csv includes an External ID field which we use to create the "With Contact"

I've tried including The source contact id as a field- failed with same message

I've tried replacing the External ID for the with contact with the External ID with the source contact.- failed with same message

Does anybody have any ideas what may be causing this?

Update 18 Nov

Found a working solution to the above- not sure of this counts as an answer or an extension of the question.

Ran an activity import against a dummy contact and the first few columns of the import ran fine. Then through a process of trial and error worked out that one column (out of 200) was causing the process to stall.

Still no idea where the source contact invalid error message is coming from- but was consistent across all failed attempts.

Setting the offending column to do not import allows the full file to import.

There are two fields in the activity custom data that share a field name (and multi-choice field labels). Don't know if the import mapping points to the same field twice.

  • Try logging out and back in - I know it sounds like the standard IT support response but it may well be your session has become stale or something. – Parvez Saleh Nov 17 '15 at 16:11
  • Had done that. And updated civi to 4.4.20. Still no dice. :( – Craig Almond Nov 18 '15 at 12:56
0

The issue we were having was with two fields in the import field mapping having the same name.

Amending the field labels through Admin>custom data to allowed us to able to link the data to the right location.

-As I said both fields shared values and labels so it's not clear why this was a problem. Or at least, became a problem between this month's import and last months.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.