0

Is this an acceptable config for an automatic discount for students?

http://d46.demo.civicrm.org/civicrm/cividiscount?reset=1
(screenshots below)

When I go to view the discount, the Automatic section is empty. On my own sites I can't get the automatic discount to apply when I view an event page that satisfies the criteria. I've seen issues like this that are marked closed on github from May. https://github.com/dlobo/org.civicrm.module.cividiscount/pull/98. I've tried the current git version and have the same issues.
So I think it's more likely that my configuration is wrong since the view of the discount shows the Automatic Discount field to be empty.

Can someone look this over and tell me if there's an error?

[enter image description here [enter image description here]

Thank you!

1

On the demo, I'm able to get the automatic discount to work. But also see the Automatic Discount as empty. See attached.

enter image description here enter image description here

  • Ahh, but the issue is for the logged in user, not the civi-admin. We're not able to test this on the demo site unfortunately. It's for events that have online registrations enabled.....sorry I left that out. And thanks. – Peter_ Nov 17 '15 at 4:53
  • Peter, sorry for the delayed response.... Automatic discounts work for logged in users too. I have just verified on a local sandbox. A non-admin logged in user with a membership is seeing an automatic discount on a live registration page. – Sanjay Jain Dec 2 '15 at 2:37
0

As it turns out, it was not an acceptable config. Removing 'country' made the auto-discount work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.