0

I have been struggling to get my initial install to work. All seemingly went well with the instal. I am sure it must be a very basic setting I have wrong.

When trying the Wordpress dashboard link to CiviCRM panel, I got a base_dir problem where I applied the recommended "fix" of adding a line to CiviCRM setting to force directory to my base wordpress instal. This progressed me a little further.

After that, now receiving ... Fatal error: Uncaught CiviCRM_API3_Exception: [unknown error: DB Error: unknown error thrown in /home/…/wp-content/plugins/civicrm/civicrm/api/api.php on line 45

Thinking of abandoning CiviCRM as a Wordpress option for my needs. The install seems to be problematic.

However, if anyone is willing and has the time to work with me to resolve the issues, I am really keen to use the product and willing to give it a good crack :)

Cheers, Garry

8
  • Can you provide a backtrace on the error? It's impossible to know what's triggering this otherwise. Commented Nov 16, 2015 at 11:20
  • Thank you Christian - I shall research to see how to turn this option on
    – Garry Owen
    Commented Nov 16, 2015 at 22:46
  • @ChristianWach I added some database entries that should have enabled backtrace, but there is nothing additional appearing on the page or in the log.
    – Garry Owen
    Commented Nov 16, 2015 at 23:17
  • Trying another clean install.
    – Garry Owen
    Commented Nov 16, 2015 at 23:59
  • Ok - same result (Isn't that the definition of insanity?) Back to original message, which did also occur after plugin activation, and PRIOR to the Install
    – Garry Owen
    Commented Nov 17, 2015 at 22:56

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.