0

I'm trying to install civicrm 4.6.10 with Drupal 7.41 on Ubuntu server 14.04 through Virtualbox. I installed successfully Drupal 7.41 and after that tried to follow the installation guide of civicrm. My first attempt was to use the "Install New module" though URL but it was not working. I have a "HTML-1" error. Related to posts I see on civicrm forum it could be due to redirection of sourceforge website that is maybe not well managed by Drupal. So I tried the alternative way, described in installation guide : manual installation. I download civicrm-4.6.10-drupal.tar.gz file from official repository and copy it in my drupal repository in /sites/all/modules folder and uncompress it. A civicrm folder has been correctly created. Coming back to Drupal administrator interface, going in Modules part, I see nothing related to civicrm. I tried to continue to follow the installation guide and tried to access to the installation script here : http://your_drupal_home/sites/all/modules/civicrm/install/index.php but file was not reachable.

What am I doing wrong ?

Thanks in advance for all help and advices you can provide to me.

  • What do you mean by "not reachable"? What error message gets displayed, if any? Are the permissions on the directory the same as for other modules? – choster Nov 16 '15 at 16:31
1

It looks like something is wrong with your Drupal installation. Does any other module work in Drupal? And also when the module is stored in the directory sites/all/modules

  • Hello, thanks for your answer. I make a try and install another module in Drupal to check. It has worked correctly. Is /sites/all/modules the right place to uncompress civicrm ? If so, is it needed to put in place specific rights on files and folders ? – Ajrarn Nov 16 '15 at 13:54
0

I assume you are following the install instructions - As you correctly questioned, yes the permissions need to be correct (user www-data needs ownership I believe)

I also assume you are using Virtual Box to test, you might find it easier to use the Bitnami CiviCRM installer

  • I will check about user www-data and also have a look to the Binami installer. Thanks ! – Ajrarn Nov 17 '15 at 16:08
0

Since I encountered pretty much the same errors as Ajrarn, I though that I should share my solution.

I couldn't for the love of me install CiviCRM via URL, no matter how hard I tried. I used wget and then copy the proper link once the download starts in a console. However, the URL wasn't correct and I tried different URLs too, but Drupal couldn't install CiviCRM.

I looked on the net for any proper tutorials and all I found was the official one which says that installing CiviCRM via URL is possible and the best choice. I finally stumbled upon an article with Rosehosting which has a different way to deploy CiviCRM with Drupal. I tried the instructions and everything went OK. I hope you'll find the tutorial useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.