I use wordpress+civicrm and all worked well since the last upgrade. Now the event report always gives the same error: '' is not a valid option for field id. On the bottom the bugs report.


CiviCRM_API3_Exception: "'' is not a valid option for field id"

#0 /wp-content/plugins/civicrm/civicrm/CRM/Core/Form/Renderer.php(219): civicrm_api3("event", "getlist", (Array:1))
#1 /wp-content/plugins/civicrm/civicrm/CRM/Core/Form/Renderer.php(184): CRM_Core_Form_Renderer::preProcessEntityRef(Object(HTML_QuickForm_text))
#2 /wp-content/plugins/civicrm/civicrm/CRM/Core/Form/Renderer.php(103): CRM_Core_Form_Renderer::updateAttributes(Object(HTML_QuickForm_text), FALSE, NULL)
#3 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Renderer/Array.php(221): CRM_Core_Form_Renderer->_elementToArray(Object(HTML_QuickForm_text), FALSE, NULL)
#4 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/element.php(415): HTML_QuickForm_Renderer_Array->renderElement(Object(HTML_QuickForm_text), FALSE, NULL)
#5 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm.php(1703): HTML_QuickForm_element->accept(Object(CRM_Core_Form_Renderer), FALSE, NULL)
#6 /wp-content/plugins/civicrm/civicrm/CRM/Core/Form.php(685): HTML_QuickForm->accept(Object(CRM_Core_Form_Renderer))
#7 /wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php(116): CRM_Core_Form->toSmarty()
#8 /wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php(101): CRM_Core_QuickForm_Action_Display->renderForm(Object(CRM_Report_Form_Event_ParticipantListing))
#9 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Report_Form_Event_ParticipantListing), "display")
#10 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Report_Form_Event_ParticipantListing), "display")
#11 /wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Submit.php(83): HTML_QuickForm_Page->handle("display")
#12 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Submit->perform(Object(CRM_Report_Form_Event_ParticipantListing), "submit")
#13 /wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Report_Form_Event_ParticipantListing), "submit")
#14 /wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(353): HTML_QuickForm_Page->handle("submit")
#15 /wp-content/plugins/civicrm/civicrm/CRM/Utils/Wrapper.php(115): CRM_Core_Controller->run()
#16 /wp-content/plugins/civicrm/civicrm/CRM/Report/Page/Report.php(76): CRM_Utils_Wrapper->run("CRM_Report_Form_Event_ParticipantListing", NULL, NULL)
#17 /wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(312): CRM_Report_Page_Report->run((Array:4), NULL)
#18 /wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:14))
#19 /wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:4))
#20 /wp-content/plugins/civicrm/civicrm.php(1133): CRM_Core_Invoke::invoke((Array:4))
#21 [internal function](): CiviCRM_For_WordPress->invoke("")
#22 /wp-includes/plugin.php(496): call_user_func_array((Array:2), (Array:1))
#23 /wp-admin/admin.php(226): do_action("toplevel_page_CiviCRM")
#24 {main}
  • Hi, Could you try on the demo site with the same report and check if it works or not?
    – Xavier
    Commented Apr 26, 2015 at 19:35
  • Hi, i tried your solution but the wordpress civicrm demo doesn't use the last upgraded version 4.6.2. On the demo all is ok. Commented Apr 28, 2015 at 8:42
  • I am also having the same problem with exactly the same stack trace. Curious because it is confined to just the Event Participant List and the Attendee List reports. Other event reports (income summary and income details) work OK. The curious thing to me is that the dashboard listing of participants works. However a "Find Participants" search results in the error, after letting me select whatever filters. any suggestions for what I might look for in the database that might be corrupted? I did not notice this right away so database has had changes go into it, reluctant to revert to backup. even
    – user404
    Commented May 1, 2015 at 5:42
  • My observation is: as soon as you try to tweak a report it will stop working. leave the reports as they are, and they work change something and you get the described error
    – user416
    Commented May 3, 2015 at 13:35
  • I had reinstalled civicrm with a new db. Now the reports appears correctly, but when I try to change something this error appears-'' is not a valid option for field id again.- I'm using worpdress 4.2.1 and civicrm 4.6.2. This is very annoying. Commented May 5, 2015 at 7:53

3 Answers 3


Found it! This bug is fixed in CRM-16333.


When you updated from (what version to what version?) were there database changes/updates included, and are you sure those ran successfully? From the stack trace and error message it sounds like a query isn't picking up the rows for the report (field 'id' may be event.id, most all civicrm tables have this field as internal identifier). The error seems like it is thrown in Civicrm/api/api.php, method civicrm_api3 and you're trying to run the report Event Participants List. Hopefully you backed up your database before doing the upgrade as is suggested. Have you tried clearing cache? The reports are compiled and cached, so you might try that first, it is not harmful and may help.


This appears to be the bug described in CRM-16477.

  • Actually, Jon, I've already applied the patch for CRM-16477, and these appear to be different, because the problem I reported in CRM-16477 is fixed, but I can also reproduce this bug. The bugs appear to both be rooted in a problem with the value that the event selector widget provides/expect and the value that CiviCRM itself provides/expects. Commented May 15, 2015 at 13:59
  • Furthermore, the problem Andrea is describing only occurs if no event is selected. If you choose an event, the search or report behaves as expected. Commented May 15, 2015 at 14:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.