2

Using .htaccess to put Wordpress in its own directory. Problem is that civicrm was installed using the subdirectory after the domain name. I try to update the path and wordpress logs out. Anything I try to do with Civicrm logs me out of Wordpress. I can't seem to get around this problem. If I edit my settings file, civicrm will not work.

  • Have you edited your civicrm.settings.php file? If that's the "settings file" you're referring to, could you explain what settings changes you made? – Jon G - Megaphone Tech Nov 19 '15 at 16:14
  • Yes, I had to change the path to the subdirectory where the Wordpress installation was in order to upgrade. However, I have .htaccess files in the root and subdirectories as documented in the help files for putting Wordpress in its own directory. – user21507 Nov 19 '15 at 22:50
1

To the best of my knowledge, CiviCRM does not work if WordPress is installed in its own directory rather than the default location. I have not tested this recently, but

  • I know it did not work in the initial versions of CiviCRM for WordPress,
  • I haven't heard about any change to this, and
  • I haven't had any reason to have WordPress in its own directory.

Notes in CRM-16421 also indicate that it's still an issue as of 4.6.

My advice is to get WordPress back out of its own directory and try again. It may not be your preference, but it's what works.

| improve this answer | |
  • Thanks. That is what I did. I also had to reinstall civicrm, then it worked. – user21507 Jan 7 '16 at 22:43
0

Probably a file permission problem... did you copy the files yourself?

You need to make sure the paths are correct (do this with the configuration file instead of the database...)

Then check the file owners and permissions in your new directory structure... The directories would be 755 and the files 644... for this to work the file owners should be the web server ...

Hope this helps...

| improve this answer | |
  • All ot those things are correct. I believe that civicrm is not checking the right setting to find the files so it doesn't think the user is logged into wordpress. – user21507 Nov 23 '15 at 22:37
  • I believe this to be a bug in civicrm. How can I log the bug or escalate this to get eyeballs looking at it . #Jon – user21507 Nov 23 '15 at 22:46
  • Hmm... I run my sites in the root on production servers and in sub directories in my test environment as I am running a few... This only happens when your paths are set wrong in the database... You can set those paths in the civicrm.settings.php which is in your civicrm directory... Those paths will override the database values so you can keep those settings local if you have a couple of installs (dev and prod for example...)... Try to set those to the exact path and see if that solves your problems, if so, it was a path in the database that was still wrong... – Serge Nov 26 '15 at 1:37
  • Thanks Serge. I must have had a bad path in the database. I had to move my website out of the wordpress directory, then I had to reinstall civicrm and everything worked. – user21507 Jan 7 '16 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.