Using Joomla and CiviCRM 4.6.10, a receipt is not being sent when using the Paypal option on our Contribution page but is being sent when using the Pay later option. The Paypal payment is being accepted and processed and the contribution is being recorded but a receipt is not being sent. I have enabled the Instant Payment Notification and Auto Return in Paypal. I am assuming this problem is related to the IPN but I do not know enough to figure out where the problem is.

3 Answers 3


Check the logs at /media/civicrm/ConfigAndLog shortly after a payment has been made but no confirmation sent.

You should see the payment Mar 15 19:13:18 [info] Contribution record updated successfully

Then you should see the contribution receipt. There may be an issue here e.g.

Mar 15 19:13:18 [info] $Fatal Error Details = Array ( [message] => The requested Profile (gid=XXXXX) is disabled OR it is not configured to be used for 'Profile' listings in its Settings OR there is no Profile with that ID OR you do not have permission to access this profile. Please contact the site administrator if you need assistance. [code] => )

If you see something like the above, the issue is that Civi cannot access the information that was entered in the profile.


This feels like an issue we mucked around with quite a bit in 4.7 & eventually solved - I am pretty sure it is fixed in the latest version

  • would be v helpful to others if you can link to the JIRA issue where this was fixed
    – petednz - fuzion
    Apr 11, 2017 at 21:24
  • Looks like this one issues.civicrm.org/jira/browse/CRM-18245 on 4.7 May 7, 2018 at 5:39
  • @user4278 - since it sounds like you are a member of the core team, or close to the core team, why the secrecy?
    – guyiac
    Sep 30, 2019 at 15:30

Upgrade CiviCrm Civicrm introduced new improved IPN url in 4.7.12 The new IPN - http://www.example.com/civicrm/payment/ipn/2where '2' is the Paypal Std. processor ID in CiviCRM.

Had tons of these issues until we upgraded to this new ipn.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.