0

I'm trying to install CiviCRM (4.6.10) on a fresh copy of Drupal 7 (7.41) but I can't start the CiviCRM installer.

Error messages: When I visit http://your_domain_or_IP_address/sites/all/modules/civicrm/install/index.php I get a Server Error 500. Looking at my logs they read:

PHP Fatal error:  require_once(): Failed opening required 'WP_PLUGIN_DIR/civicrm/civicrm//CRM/Core/ClassLoader.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/usr/local/php56/lib/php') in /home/hostname/public_html/test/d7/sites/all/modules/civicrm/install/index.php on line 75
PHP Warning:  require_once(WP_PLUGIN_DIR/civicrm/civicrm//CRM/Core/ClassLoader.php): failed to open stream: No such file or directory in /home/hostname/public_html/test/d7/sites/all/modules/civicrm/install/index.php on line 75

From Drupal

Notice: Undefined index: description in drupal_check_module() (line 1232 of /home/hostname/public_html/test/d7/includes/install.inc).
(Currently using CiviCRM settings does not exist CiviCRM settings file does not exist. It should be created by CiviCRM install)

What I've tried: setting folder permissions to 755 or 777. I have uploaded the CiviCRM files via ftp and also using the URL. I have re-installed Drupal 7.

I was able to successfully install CiviCRM on Wordpress on the same server but I'm stuck on the Drupal install.

To be clear, I downloaded and uploaded different CiviCRM installation. One specific to Wordpress (for Wordpress) and one for Drupal. The modules show up in my Drupal Modules section.

Any idea what I can do to kick start the installer?

  • Can you clear the browser cache/cookies(mostly using Ctrl+Shift+Del) and check ? – jitendra - fuzion Nov 23 '15 at 5:37
  • That worked! I tried it in an incognito window and the installation came up. I can't believe I didn't try that :( Thanks for the suggestion! – Alex K Nov 23 '15 at 14:59
2

It mentions WP_PLUGIN, are you sure you downloaded the civicrm version for drupal, and not the one for wordpress?

You can't just re-use the same civicrm code base between wordpress and drupal, you'll need to download the CMS specific version again

X+

  • I thought the same thing when I saw that but I got it from their download page and the file is named "civicrm-4.6.10-drupal". Odd. I re-installed it twice as well and it shows up in my Modules in Drupal? Also the installation file I have uploaded looks like it is both for Drupal and Wordpress. There is an if statement checking if the CMS is Drupal or Wordpress. – Alex K Nov 23 '15 at 14:53
2

"CiviCRM has been successfully installed"!

The solution in my case was suggested by "jitendrapurohit" by clearing my cookies and cache. I re-opened the installer in an incognito window and it came up the first time and installed successfully.

  • I'm pleased that worked. Could you mark this as the accepted answer in case other people have the same problem - click on the tick. – William Mortada Nov 24 '15 at 18:30
0

My thoughts too Xavier, it is strange that it starts looking for WP_PLUGIN if you are indeed using the Drupal installer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.