4

I have a Drupal multisite build and after upgrading to civi 4.6.10 noticed the default text editor for bulk mailings defaults to CKEditor...despite my settings in administor/customise data and screens/display preferences being set to TinyMCE.

If I send individual emails out the editor is TinnyMCE but for bulk mailings it is CKEditor? Despite trying all options in display preferences the bulk email adeitor stays as CKEditor.

Now, even though the template looks ok in mailings, when i send a bulk email the text stretches to either the full page width or the width of the paragraph (whichever is shortest) even if the text is placed inside a table. Using the same template in invididual emails the formatting is correct.

ie. I have a table cell that is set as say 200 px wide if i add text and send as an individual email it is fine but when I send as bulk email the text forces the table cell to stretch to the width of the text or page width.

I've tried to give an example of what it looks like below;

In individual emails with TinyMCE

Lorem ipsum dolor sit amet,
consectetur adipiscing elit,
sed do eiusmod tempor
incididunt ut labore et
dolore magna aliqua. Ut enim
ad minim veniam, quis
nostrud exercitation ullamco
laboris nisi ut aliquip ex ea
commodo consequat.

The same template in bulk emails stretches to full page width looking something like this

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.

I am completely baffled by this and any help/advise would be welcome.

Cheers Robbie

  • I have realised that CKEditor is actually inserting   instead of a space thus creating one continuous word. Unfortunately i have no idea how to stop this...help...!!! – robbiemc Nov 27 '15 at 16:03
1

I strongly suspect that what you're seeing is a side effect of CiviCRM dropping support for TinyMCE in core. If upgrading to 4.7 is an option, I suspect that you can solve this problem by installing the TinyMCE extension.

Of course, if CiviMail is important to you, then upgrading to 4.7 shouldn't happen until these two bugs are closed in a released version of CiviCRM:

0

Try with drupal WYSIWYG editor.

  • This doesn't solve the problem, since the problem is that CiviCRM isn't respecting the WYSIWYG setting in CiviMail. – Jon G - Megaphone Tech Feb 14 '16 at 16:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.