2

The answer is (I hope) 'yes' but I can't get it to work - see How to select a default event in webform where event is repeating I'm pretty sure the Views side is working as it generated a url that when clicked gave me the webform with the correct event selected (this is on a Views screen). But when I run the webform I get '- None -' displayed in the event list box. Yes, I have checked "Allow events to be autoloaded from URL checked." Code is at the latest level - I went back to Webform 7.4.9 and Webform 7.4.11 to see if there had been a regression but no change.
So now I'm wondering if this is a bug in Webform-CiviCRM?

  • What exactly is the url argument you are giving it? – Coleman Nov 28 '15 at 19:24
  • The url in rewrite section of the global custom text field is node/27?event1=[id] Which doesn't square with the help in webform which shows 2 event ids (but that didn't work either). This is where I am registering all contacts for the same event, although there is only one contact in this case. – Andy Clark Nov 28 '15 at 19:27
  • And is [id] one of the available events in the select field? It won't pick something that's not there. – Coleman Nov 28 '15 at 19:50
  • Not sure what you mean, but I just clicked on the first of the listed events in the Views screen and it gave me this url dcm-admin.org.uk/node/25?event1=163 - this is the correct event. But when I run the webform it doesn't pick this or any event. – Andy Clark Nov 28 '15 at 19:56
  • I mean, have you added a "select" field to the webform containing that event as one of the options? – Coleman Nov 28 '15 at 20:00
0

I believe this has been implemented now so that there is a setting on the Event section of the webform's civicrm tab so that you can 'allow events to be autoloaded from URL'

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.