0

Following the directions on this page. WP 4.3.1, standard LAMP install. All plugins up-to-date except CiviCRM. The plugin is obviously active. Using putty.exe, I remove the civicrm directory and untar the 4.6.10 directory in its place. When I use the wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1 upgrade URL, I get the insufficient permissions notice. I'm logged in as the user 1 administrator. Settings file is where it should be. No files have wonky read-write or owner perms. I'm at a loss as to why I am unable to get past the upgrade URL step. I'd be grateful for suggestions.

  • Have you given permission to apache user over the new folder? Try chown www-data -R /path/to/wp-plugins – Andrei Dec 1 '15 at 11:52
  • folder and file permissions are uniformly 755 and 644. All other plugins install as expected. – Chris Dec 1 '15 at 11:55
  • I had a similar issue and even though the file permission were set properly, until I've gave permission to apaches user over the folder civi wouldn't install/upgrade – Andrei Dec 1 '15 at 12:01
  • I'll give it a shot. (Later tonight.) Please stand by. Thanks. It makes sense. – Chris Dec 1 '15 at 12:07
  • Let us know if it worked. By the way, I just saw you are mentioning a tar file, would it be possible that you have download the Drupal version instead of Wordpress? For WordPress it should be a zip file not tar – Andrei Dec 1 '15 at 12:13
2

Andrei has not responded, so I will state the answer here. The problem was that I downloaded the .gz file for Drupal rather than the .zip file for WordPress. Once that was addressed, the install went as flawlessly.

0

Can I check if you replaced the civicrm.settings.php file? (In Drupal, the settings file is in a different folder from the CiviCRM module, but in Wordpress it remains in the plugin folder, so it gets deleted/overwritten when you unpack the new version.)

Alternatively, can I check whether it's your own server or a hosted server? I've had problems installing CiviCRM on a shared server because the permissions I assigned to the database user weren't actually being saved - for some reason it didn't affect the WP installation, just CiviCRM. I know it seems unlikely the permissions would change after you've already installed CiviCRM, but if you're not running the server yourself, it's worth double checking.

  • It's a hosted vps -- greengeeks. It wouldn't surprise me if the problem were database-related. However the civicrm.settings.php file was saved at the base of the civicrm folder as suggested in the directions. I'll try untarring again and recursively change folder and file permissions to 755 and 644 respectively for the civicrm directory. Could it be this simple: Is it possible that the standard command tar -xzvf <filename>.gz is causing problems with umask 022 set in .bash_profile? – Chris Dec 1 '15 at 12:06
  • I'm afraid I'm not really familiar with bash - most of what I do is either on XAMPP or on shared hosts where I don't have ssh access, and have to use cPanel. (I say 'have to' - I ain't proud. If I can avoid using a command line, I will :) – liblogger Dec 1 '15 at 13:05
  • I agree with @Andrei that the WP version of CiviCRM should be .zip, so check that first! Then check that the WP and CiviCRM database details are still in your settings file, and check your database user permissions. – liblogger Dec 1 '15 at 13:20
  • The zip for wordpress solved it. I downloaded the drupal version by mistake. I'm blaming it on the fact that I still hadn't bought my new glasses. Thanks - that's got it. @Andrei, if you'll add your answer, I'll credit you. Thanks! – Chris Dec 16 '15 at 22:52
0

Use drush command to upgrade civicrm

drush civicrm-upgrade

  • Wordpress install. Not drupal. Answer found by Andrei. – Chris Dec 22 '15 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.