0

I'm trying to update civicrm from version 4.4 to 4.6. When I try to run the update script, it stalls at "Executed: Upgrade DB to 4.5.beta2"

I found this similar post for drupal (https://forum.civicrm.org/index.php?topic=26648.0) but the answer that worked for him won't work for me. I checked and this code is already there in civicrm.settings.php:

require_once 'CRM/Core/ClassLoader.php';
CRM_Core_ClassLoader::singleton()->register();

I risked refreshing the page once, and it actually kept going a little bit further to this point: [Executed: Upgrade DB to 4.5.beta9: SQL]

Looking at my inspect element console, I see this ajax warning:

http://mydevurl.com/wp-content/plugins/civicrm/civicrm/bower_components/jquery/dist/jquery.js (9664)

POST http://mydevurl.com/wp-admin/admin.php?   page=CiviCRM&q=civicrm/upgrade/queue/ajax/runNext 404 (Not Found)
send @ jquery.js:9664
m.extend.ajax @ jquery.js:9215
runNext @ admin.php?page=CiviCRM&q=civicrm%2Fupgrade%2Fqueue%2Frunner&reset=1&qrid=CRM_Upgrade:687

Thanks for your help

  • I found this post after having an upgrade from 4.2. to 4.6.11 freeze on me when it got to the first 4.6.x upgrade script. I tried refreshing the screen and it continued to the end, fortunately. That said, upgrading in smaller steps make eminent sense; that was going to be my next move. – millionleaves Jan 8 '16 at 6:22
2

Try running the upgrades more incrementally (e.g. update to 4.4.20, then to 4.5, then 4.6, etc). (I've had the upgrade process stall on me when trying to move more than a handful of versions at a time.)

0

Don't try to upgrade from civicrm 4.4 to 4.6. Try to do it in steps (4.4 -> 4.5 -> 4.6).

0

We finally resolved this issue by hiring an expert who updated the CiviCRM database on a different server. There was a conflict with the web hosting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.