1

I use webform integration for event registration, and this has worked smoothly in the past. Users can select which of several events they would like. I don't believe I've changed anything about the setup to break it, but I guess I must have updated something without noticing. Now, however, anyone who uses this form becomes registered for all events listed. The webform results page shows which event an individual chose, but the contacts are registered for all the events in civicrm. This is wreaking havoc, as you can imagine. Has anyone else run into this issue? How did you fix it?

0

I just set up a test webform with a "user select" list of events, and diligently tried to get it to misbehave, but it wouldn't. It seems to be correctly registering and unregistering me for the events I select on the form, whether I'm logged in or anonymous.

I would suggest you:

  1. Ensure you are using the latest version of everything
  2. Try creating a new webform as a test to make sure the problem isn't limited to just your one form.
  3. Create an issue in the webform_civicrm queue with lots of details about how to reproduce the bug, including screenshots of your form configuration.
  • I am working with the latest webform & webocrm civicrm, but my civi needs updating so I'm gonna do that over the weekend and if that doesn't fix it, create an issue in the queue, thanks for linking to it! – naomisl Dec 16 '15 at 22:48
  • For anyone else who has this issue-- my current workaround is to give users a dropdown listbox with two options. I labeled registered "Yes" and expired "No," and made expired the default choice. This way only people who choose "Yes" are registered for the event. – naomisl Dec 16 '15 at 22:49
  • Having updated everything, the issue still persists so I've created an issue, here: drupal.org/node/2641594 – naomisl Dec 28 '15 at 20:41
2

Can you check if "User Select" is still part of the Events list on the CiviCRM tab?

It MIGHT be somehow possible that the Webform field still exists but lost connection to the CiviCRM functionality. In that case the visitor still choses the event in the webform, but CiviCRM registers to all events.

  • Good thought! It is still set to "user select" though, and the webform field keys are auto-generated with civi names. Do you think they could have lost their connection somehow anyway? – naomisl Dec 2 '15 at 22:49
  • It should not be possible. The connection is done via the auto-generated name. I would try to remove this event subscription possibility via the CiviCRM tab. If webform field is then not removed you know the connection is lost. In that case make sure the webform field is also removed. Then enable it again via CiviCRM tab. – Catorghans Dec 3 '15 at 8:26
  • I've found that a null response, when the user chooses nothing in the exposed "user select," is resulting in registration for the event. It does this even when I delete and re-enter all the events. This is why users end up registered to all events on the form. Do you have any ideas of how to work around or fix that? It is definitely a new issue, as I've successfully used this same approach on the same form before. – naomisl Dec 10 '15 at 19:06
  • I'm also not getting the following error message when updating the webform field, which I was not getting several days ago when I posted this question: Notice: Array to string conversion in wf_crm_admin_component::preprocessComponentsForm() (line 555 of /home/makom/www/www/sites/all/modules/webform_civicrm/includes/wf_crm_admin_component.inc). – naomisl Dec 10 '15 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.