0

In my contribution page, there is not an option to add a profile: enter image description here

The dropdown menu doesn't work (doesn't exist) and even if I type in the name of a profile that I have created, it doesn't actually do anything. We have PayPal Standard and because we have that set up as a payment instrument thru CiviCRM, it isn't a button that we can add settings to from PayPal, so PayPal doesn't collect that information for us. We need to be able to collect donor addresses to send them their donation receipts. If the donors are already in our database, I can pull a report from CiviCRM but if they aren't all we have is a name and email address.

Is there a workaround? Or am I doing something wrong? I have several profiles on CiviCRM--some of the standards and some that I've created and none are available.

I looked at the suggestions here but none worked. My page (here) is on WordPress. Also, I am a total novice at coding, so the more info you can give if suggesting going into the code, the better. Thank you!

  • Just delete the civicrm temporary folder (../files/civicrm/templates_c/en_US), your profile option will start working. – Prem Patel Dec 3 '15 at 7:07
  • @PremPatel I just tried that but basically as soon as I reload the page or do anything the file comes back? – Terra Dec 3 '15 at 7:29
  • Check your resources url. Is it valid URL? – Prem Patel Dec 3 '15 at 8:49
  • As far as I can tell...I haven't changed it since setting up CiviCRM. – Terra Dec 11 '15 at 22:08
  • Sometimes it is change after civicrm upgrade. – Prem Patel Dec 14 '15 at 6:39
1

I had this problem last month and also posted my question on Stack Exchange - though I realize that most people who looked at my question and yours wouldn't think they were the same! Check it out: Backbone isn't loading on Civi 4.6.11/WP 4.4.1

If you pull up your Developer Console (press F12 in your web browser when viewing this page, then check the "Console" tab, you should see the same errors I reference in my question. If so, the answer is the same.

In less-technical terms - CiviCRM uses a pre-built package called "Backbone" to build the profiles on the page you're viewing. Some Wordpress themes also use Backbone, and sometimes they conflict, which causes what you're seeing. If you switch to a theme without this problem (for instance, the twentyfifteen theme), you should see the problem go away.

To fix my problem, you can use a different theme, or you can try to hack your theme. I took the latter route; I created a child theme (there's lots of Wordpress documentation on that), and I overrode the objectionable code with my own code.

0

It's basically civicrm cache issue, to fix this issue you need to clear the cache and delete civicrm temporary folder (../files/civicrm/templates_c). If it will not help you then you need to check java script console error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.