2

I have manually edited the ckeditor config file: packages/ckeditor/config.js to enable the Subscript and Superscript buttons by commenting out this line //config.removeButtons = 'Underline,Subscript,Superscript

this is working correctly in my local environment but when i deploy it on production, the Subscript and Superscript buttons are not available.

clearing cache (drush cc all, /civicrm/clearcache, browser cache) doesn't help, the only difference between my local and production is https.

How can i solve this issue?

1

Once you upgrade to 4.7 it will be super easy due to the new configurator UI.

See https://civicrm.org/blogs/colemanw/big-changes-wysiwyg-editing-47

4.7 is now available for beta testing, be sure to give it a try :)

  • Many thanks @Coleman, this has been resolved in production by cleaning varnish cache, Still testing 4.7 though :) – Kboy Dec 10 '15 at 9:52
0

Check out the answers to

How do I override the default CKEditor configuration?

and

Is there a way to enable or install the full version of CKEditor in CiviCRM 4.6.x?

Might be some help there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.