6

I'm cleaning up membership data that was imported and need to make changes in the "member since" field. Some people have been members since the 80's. When I try to add pre-1995 dates, I get the following error:

Please enter a date between 01/01/1995 and 12/31/2025

How can I increase the date range so that I can add correct historical membership data? Thanks, Kate

15

For CiviCRM 4.6+ go to Administer menu > Customize Data and Screens > Date Preferences. From there, change the Start Offset of SearchDate.

For CiviCRM versions before 4.6, this is part of the Advanced Date settings linked from Administer > Localization > Date Format.

  • Works also for Relationship dates! – ñull Jun 23 '17 at 9:46
2

Further to Jon's helpful answer, for CiviCRM 4.7.12 (and possibly earlier) the date preference setting that needs to be changed is 'activityDate', as the description makes clear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.