2

Got reports from some of the users about this error, which happens when submitting the contribution payment form. Because of this error many users are having issues with registration/payment. Haven't been able to reproduce it.

Sorry but we are not able to provide this at the moment.
We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site adminstrator for assistance.

Site Administrators: This error may indicate that users are accessing this page using a domain or URL other than the configured Base URL. EXAMPLE: Base URL is http://example.org, but some users are accessing the page via http://www.example.org or a domain alias like http://myotherexample.org.

Error type: Could not find a valid session key.

Here is the backtrace from the log files:

Oct 01 12:19:07  [info] $backTrace = #0 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(387): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(877): CRM_Core_Error::fatal("We can't load the requested web page. This page requires cookies to be enable...")
#2 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(891): CRM_Core_Controller->invalidKeyCommon()
#3 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Form/ContributionBase.php(229): CRM_Core_Controller->invalidKeyRedirect()
#4 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Form/Contribution/Main.php(69): CRM_Contribute_Form_ContributionBase->preProcess()
#5 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Form.php(436): CRM_Contribute_Form_Contribution_Main->preProcess()
#6 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/QuickForm/Action/Display.php(93): CRM_Core_Form->buildForm()
#7 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Contribute_Form_Contribution_Main), "display")
#8 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contribute_Form_Contribution_Main), "display")
#9 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(356): HTML_QuickForm_Page->handle("display")
#10 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(331): CRM_Core_Controller->run((Array:3), NULL)
#11 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(75): CRM_Core_Invoke::runItem((Array:15))
#12 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#13 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm.php(506): CRM_Core_Invoke::invoke((Array:3))
#14 [internal function](): CiviCRM_For_WordPress->invoke("[civicrm component=\"contribution\" id=\"1\" mode=\"live\"]\n")
#15 /var/www/{domain_name}/wp-includes/plugin.php(213): call_user_func_array((Array:2), (Array:1))
#16 /var/www/{domain_name}/wp-includes/post-template.php(221): apply_filters("the_content", "[civicrm component=\"contribution\" id=\"1\" mode=\"live\"]")
#17 /var/www/{domain_name}/wp-content/themes/{theme_folder}/template-membership-signup.php(182): the_content()
#18 /var/www/{domain_name}/wp-includes/template-loader.php(74): include("/var/www/{domain_name}/wp-content/themes/{theme_folder}/template-membership-signup.php")
#19 /var/www/{domain_name}/wp-blog-header.php(16): require_once("/var/www/{domain_name}/wp-includes/template-loader.php")
#20 /var/www/{domain_name}/index.php(17): require("/var/www/{domain_name}/wp-blog-header.php")
#21 {main}

also

Oct 05 16:46:33  [info] $backTrace = #0 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(387): CRM_Core_Error::backtrace("backTrace", TRUE)
#1 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(877): CRM_Core_Error::fatal("We can't load the requested web page. This page requires cookies to be enable...")
#2 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(891): CRM_Core_Controller->invalidKeyCommon()
#3 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Controller/Contribution.php(72): CRM_Core_Controller->invalidKeyRedirect()
#4 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(318): CRM_Contribute_Controller_Contribution->invalidKey()
#5 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Controller.php(209): CRM_Core_Controller->key("CRM_Contribute_Controller_Contribution", TRUE, FALSE)
#6 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Contribute/Controller/Contribution.php(53): CRM_Core_Controller->__construct("CiviContribute", "null")
#7 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(326): CRM_Contribute_Controller_Contribution->__construct("CiviContribute", TRUE, "null", NULL, "false")
#8 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(75): CRM_Core_Invoke::runItem((Array:15))
#9 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#10 /var/www/{domain_name}/wp-content/plugins/civicrm/civicrm.php(506): CRM_Core_Invoke::invoke((Array:3))
#11 [internal function](): CiviCRM_For_WordPress->invoke("")
#12 /var/www/{domain_name}/wp-includes/plugin.php(496): call_user_func_array((Array:2), (Array:1))
#13 /var/www/{domain_name}/wp-settings.php(353): do_action("init")
#14 /var/www/{domain_name}/wp-config.php(97): require_once("/var/www/{domain_name}/wp-settings.php")
#15 /var/www/{domain_name}/wp-load.php(29): require_once("/var/www/{domain_name}/wp-config.php")
#16 /var/www/{domain_name}/wp-blog-header.php(12): require_once("/var/www/{domain_name}/wp-load.php")
#17 /var/www/{domain_name}/index.php(17): require("/var/www/{domain_name}/wp-blog-header.php")
#18 {main}

After some digging into this issue, found this https://issues.civicrm.org/jira/browse/CRM-9483 , which indicates that this has been fixed in version 4.3, but we are using version 4.6.8.

This is happening way to often to be a disabled cookies issue. Also made sure that its not the URL issue ( two possible reasons written in the error message above ).

2

check your base url in civicrm.setting.php file. May be you have added www in your URL and in your actual URL there is no www.

Example: If you site URL is http://example.com then your base URL in civicrm.settings.php must be

define( 'CIVICRM_UF_BASEURL' , 'http://exapmle.com/');

Not

define( 'CIVICRM_UF_BASEURL' , 'http://www.exapmle.com/');

  • 1
    also worth checking http vs https. In the end we just switched the entire site over to https to avoid things like this. – Andrew West Dec 11 '15 at 12:43
  • We have forced ssl for all pages and also to the url without www. So if user goes to http://www.example.com/ .. they will be redirected to https://example.com/ . And in base URL we have : $protocol = (443 == $_SERVER['SERVER_PORT']) ? 'https' : 'http'; define( 'CIVICRM_UF_BASEURL' , $protocol . '://' . $_SERVER['HTTP_HOST'] . '/' ); – Pellumb Hasani Dec 11 '15 at 13:11
  • Any idea on why I would be getting that error? @AndrewWest – Pellumb Hasani Dec 14 '15 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.