3

Using version 4.6.10. I can reproduce this problem on the Demo site.
This is the problem:

  • Create a donation page with an "other amount" option in addition to fixed price options.
  • Open the live-page or test-drive page link
  • Under Donation Amount, choose "Other Amount" radio button
  • Most of the fields on the page disappear: the name and address fields, the credit card fields, etc.
  • Input an amount into the "Other Amount" box, and press enter, sometimes the fields briefly reappear.
  • But as soon as you scroll with your mouse, the fields disappear again, and you find that there are pink error messages at the top of the page asking you to fill in the missing form fields.
  • However, you can't fill in the missing fields because they have disappeared from the form.

Since I can reproduce this on the demo site, I suspect it may be a bug. But I'm reluctant to report a bug until I've had some independent confirmation.

Any help would be most appreciated!

Leslie

2

Update: This is a bug - Reported at https://issues.civicrm.org/jira/browse/CRM-17735

---original answer---

I am not seeing this on the demo. On clicking the Other Amount radio button, the credit card information section disappears. This is the correct/expected behaviour as the amount is Zero. Adding an amount makes that section reappear.

This could be a browser issue - please test with other OS/Browser combinations. I used Ubuntu Mate with FireFox 42.0

  • Thanks Sanjay. I have tried this in three browsers: Firefox 42, Chrome 47, and Microsoft Edge. I am on a Windows 10 machine. In all three browsers, the credit card section fails to reappear after adding an amount in the Other Amount box. Instead, I get the pink messages asking for the necessary information, but the credit card section is absent. – lesliejmatthews Dec 14 '15 at 0:33
  • I also just tried this on the Demo site using Firefox running on Ubuntu Desktop 15 in VirtualBox. Same behavior: credit card section fails to reappear after adding an amount in the Other Amount box, and pink missing info messages appear at top of page. – lesliejmatthews Dec 14 '15 at 2:20
  • Leslie, Which demo are you using? I was testing on Drupal. It might also help testing if you can provide a link to your site where this is happening. – Sanjay Jain Dec 14 '15 at 13:59
  • I am also testing on drupal. d46.demo.civicrm.org – lesliejmatthews Dec 14 '15 at 21:52
  • So it appears that this error is related to using the enter key instead of tab or mouse, after entering an "other amount." Using the enter key to move to the next field causes the errors. I still think this may be a bug, because users could easily run into this problem if they use the enter key, and once you hit enter, there's no way to recover. – lesliejmatthews Dec 17 '15 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.