3

Version 4.6.2 Platform: Wordpress Payment Processor: Paypal Payments Pro

So I just noticed that in any membership or recurring contribution email when you go to update the billing address (the token is {ts 1=$updateSubscriptionBillingUrl}) you get this error: Fatal error: Cannot use object of type CRM_Core_Payment_PayPalImpl as array in /wp-content/plugins/civicrm/civicrm/CRM/Core/Payment/Form.php on line 212.

I then realized that when you go in an an admin and try to do edit billing details you get the same error.

I am not sure if this is new since I upgraded or has been around for a while, but it seems like a pretty large issue. In all my searching I havent found anyone with the same or even near the same issues so I wonder if this is a new bug.

The lines of code at 212 are

public static function getPaymentFields($paymentProcessor) {
  $paymentProcessorObject = CRM_Core_Payment::singleton(($paymentProcessor['is_test'] ? 'test' : 'live'), $paymentProcessor);   #this is 212
  return $paymentProcessorObject->getPaymentFormFields();
}

Any ideas what the issue is and how I might start to solve it? Ill report anything I come up with here.

Thanks!

closed as unclear what you're asking by Coleman Jun 8 '15 at 22:05

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • What's the url of the page where you have this error? (you can replace your domain name by example.org, that's the path that I want to know) – Xavier Apr 28 '15 at 9:40
  • haha yeah thats helpful, its any update to billing so "example.org/?page=CiviCRM&q=civicrm/contribute/… – LorenV Apr 28 '15 at 19:15
  • Still getting this error for myself in the admin site and also any contributor or member who tries to update their billing info. Super confused. – LorenV May 6 '15 at 18:26
  • do you get the same behavior on the demo sites? – Donald Lobo May 31 '15 at 16:18
  • Any luck here? I'm having the same problem. – Cullen McGough Dec 15 '15 at 19:54