3

After migrating from Drupal to Wordpress, my payment processor is no longer working.

After having gone to the payment processor I am redirected to the URL: ?page=CiviCRM&q=civicrm/payment/ipn&processor_name=Sagepay.....

The error I get is: You do not have permission to execute this url.

Any help in getting to the bottom of this would be appreciated!

1

A bit of a stab here, but have you checked the Wordpress Access Control (Administer > Users and Permissions > Permissions (Access Control) > WordPress Access Control) settings to make sure that Anonymous users have access to the "CiviContribute: make online contributions" permission?

  • Sadly it is enabled. I've hacked it a little for now by adding 'payment' to the list of allowable arg2's in civicrm.php. I'll up date with the answer once I track to down properly. – Brian Dec 17 '15 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.