2

I just installed fresh CiviCRM 4.6.10 on Wordpress 4.4

Everything seems to be working fine and it looks like this crm is perfect for our needs but I am running into one problem-

If I go to Administer > Administration Console on the dropdown menu, every single link on that page brings me to a 404 not found error. EX: clicking on Organization and Contact info this is the URL I am getting a 404 not found http://(site)/civicrm/admin/domain?action=update&reset=1

But, if I go on the dropdown menu to Administer > Administration Console > Configuration Checklist and edit settings from links in there.. everything seems to be fine. URL for Organization Address and Contact Info is http://(site)/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fdomain&action=update&reset=1&civicrmDestination=%2Fwp-admin%2Fadmin.php%3Fpage%3DCiviCRM%26q%3Dcivicrm%2Fadmin%2Fconfigtask%26reset%3D1

Seems like something is wrong and the full URL isn't linked in the Administration Console?

Any help is appreciated. Thanks

  • The path in the links that give you a 404 are the paths where CiviCRM would be found by default if installed under Drupal. The links that work are appropriate to Wordpress. I can't think of any reason why this would happen in one place but not another - I just checked my Wordpress site and those links are correct. – Jon G - Megaphone Tech Jan 18 '16 at 0:36
  • I'm having a similar issue but my problem is I cannot access the link provided in the answer given by William - it returns a 404 Page Not Found Error. Can anyone provide any advice on how to solve the issue? I feel I may have to change something in the database but I'm not sure what to change. I've had a look at the civicrm_domains table but I'm not sure what I can change there to make my links work, or if anything there needs to be changed. Thanks, Monica. – user2665 Jan 21 '16 at 13:57
1

Have you set the base URL correctly?

You can set this at: http://[site]/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/updateConfigBackend&reset=1

The default setting for this is: http://[site]/

See the Wiki for more details.

  • 1
    so my base URL should be http://[site]/wp-content/plugins/civicrm/civicrm/ or http://[site]/ ? – chrism Dec 17 '15 at 15:37
  • Sorry, it should be http://[site]/. I've updated the answer to reflect this. – William Mortada Dec 17 '15 at 15:45
  • yes that is what is set there – chrism Dec 17 '15 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.