1

When I click on the {mailing.viewUrl} inside an email the URL formed is as follows:

www.http.com//www.example.com.au......

I am not sure why the www.http.com is replacing http:

Cheers Martin Fuggle

3
  • What about the other urls, like subscribeURL or optoutURL. If in all urls i suspect something wrong in the general token url formation Commented Apr 28, 2015 at 14:03
  • Unsubscribe and Opt Out URLs function correctly. It is only the mailing.viewUrl that returns the faulty URL Commented Apr 28, 2015 at 21:38
  • in 4.6.2 this is a code issue, see: civicrm.stackexchange.com/questions/3057/…
    – MetroEast
    Commented Nov 17, 2016 at 22:35

2 Answers 2

1

Ooops - my mistake. I had included "http://" in the href before the token. Sorry for the trouble and the answers

2
  • 1
    so its fixed, right? Might want to comment and edit the original post Commented Apr 29, 2015 at 0:36
  • @DonaldLobo Since the question and answer might be helpful to others, I believe proper StackExchange protocol is to accept this answer. If the question/answer pair is not helpful, then Martin should delete the original question.
    – choster
    Commented Apr 30, 2015 at 15:39
0

Go to Resource URL Settings (Administer menu > System Settings > Resource URLs). I'd guess that you'll see an setting there containing a malformed URL.

If not, please update your question with your version number and the values you see in that screen.

1
  • Resource URLs are just fine. Version is 4.5.8 Commented Apr 28, 2015 at 21:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.