3

In CiviMail 4.6.10 on Joomla 3.4.5, clicking on Browse Server button opens Kcfinder popup window. Kcfinder is contained in CKeditor insert image toolbar function. No images populate and internal links result in error:

Firefox doesn't know how to open this address, because one of the following protocols (kcact) isn't associated with any program or is not allowed in this context.

All major browsers same result. Cleared all browsers and CiviCRM cache to no avail. (The CiviCRM demo is still at 4.6.0 which doesn't have this feature.) See image below:

enter image description here

  • Not sure why the demo version of CiviCRM on Joomla is out of date, but the demo versions for Drupal and WordPress use the latest version of CiviCRM (currently 4.6.11): civicrm.org/demo. Perhaps you could test it on that? – William Mortada Dec 22 '15 at 17:46
  • Did anyone find a fix for this issue? I'm on 4.6.14 and 4.7.3 in Joomla 3.4 and I'm seeing the same screen. It was working before upgrade to this latest version. I have the resouce directories and URLs in ok. In Firebug I am seeing this error: TypeError: _.support is undefined _.support.zip = true; Wonder if anyone has a fix so I can use image upload and browse again? – Dave Mar 11 '16 at 13:20
2

KCfinder is very sensible with the path to image storage. It configured path to the storage must match the path send by the JS component exactly! It doesn't work well with symbolic links on unix.

On windows servers, there may be problems with capital letters and small letters too.

I'm not shure, if this may be the problem in this case, but just double check all configured pathes.

  • Yes, all paths are correct under Administer=>System Settings=>Directories and =>Resource Urls. Permissions are 755 for folders and 644 for files recursively ~/media/civicrm/persist/contribute/. Please advise. – BruceW Dec 21 '15 at 21:42
  • 1
    did you use a path starting with '~'? If the answer is yes, please try the full path... If this doesn't work... I don't have any hints anymore... Pathname was the problem in my case... ;-) – Tiggr Dec 21 '15 at 21:58
  • Yes, I used the full path, /home/account/public_html/media/civicrm/persist/contribute/ . My use of prepending with "~/media/" was to just mask the full webroot path. – BruceW Dec 22 '15 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.