2

The reminder email for pledge payments includes a link that points to a page on the admin side of wordpress that requires a login. How can I change this setting in CiviPledge to point to a publicly accessible page?

Here's a sample of the link

Pledge Payment Reminder

In response to comments below:

1 - I am using the default message template for Payment Reminders.

2 - The Old/New Base URL in Settings - Cleanup Caches and Paths shows "https://lofcenter.org/"

3 - The civicrm.settings.php shows the following: if (!defined('CIVICRM_UF_BASEURL')) { define( 'CIVICRM_UF_BASEURL' , 'https://lofcenter.org/' );

  • Thank you, Jorge, for the added info. Do any other Civi email messages create links with the additional "admin-only" info in the URL? Put another way, do any of your other templates that use the 'crmURL' token create the same problem? I know one template that uses 'crmURL' is the Contribution Receipt - online. – Allen Hutchison Dec 31 '15 at 15:40
  • Another idea: could you send a test message to yourself using the 'crmURL' token and see what happens with the link? – Allen Hutchison Dec 31 '15 at 15:41
  • My apologies, I've sent an email from CiviCRM to myself using {crmURL} in the message body and I receive {crmURL} in the email, no link. – V3rmie Dec 31 '15 at 15:53
  • Hey @AllenHutchison, I did try an online contribution and the only link in the email was to "tell a friend" that link is lofcenter.org/CiviCRM?page=CiviCRM&q=civicrm/contribute/… Pledge Payment reminders still point to a login page instead of the pledge payment page. Any other ways to trouble shoot this? – V3rmie Jan 14 '16 at 19:59
1

This answer is for how to change the template issuing the email in question. However, I don't know that the issue you're facing is due to the template. See other answer.

The template for Pledge Payment Reminders is found in Communications or CiviMail's settings.

From the black menu bar:

Administer > Communications > Message Templates

OR

Administer > CiviMail > Message Templates

On the Message Templates screen, click on the tab at the top for "System Workflow Messages." Scroll down and you should see an edit link for "Pledges - Payment Reminder."

On that edit screen, you can make any changes you need including changing the link. Don't forget to make your changes in both the HTML Format and Plain-Text Format.

Before making your changes, I'd recommend copying and pasting the default template to a text document just to have it saved in case you need to revert back in the near future.

1

To summarize the issue to make sure I understand it:

Your example checksum link is as follows:

https://lofcenter.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=1&cid=3305&pledgeId=5&cs=da386e473e8c85e6d2f948217cc28625_1451424231_168

The example Wordpress checksum link per Tokens on the CiviCRM wiki appears as:

http://www.myorganization.org/?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=N&{contact.checksum}&cid={contact.contact_id}

If you are using the default message template for Payment Reminders (please let us know as an Edit in your answer if it is somehow different), here is the relevant template code with tokens:

{if $contribution_page_id}
     {capture assign=contributionUrl}{crmURL p='civicrm/contribute/transact' q="reset=1&id=`$contribution_page_id`&cid=`$contact.contact_id`&pledgeId=`$pledge_id`&cs=`$checksumValue`" a=true h=0}{/capture}
     <p><a href="{$contributionUrl}">{ts}Go to a web page where you can make your payment online{/ts}</a></p>
{else}
     <p>{ts}Please mail your payment to{/ts}: {$domain.address}</p>
{/if}

So, the extra bit getting inserted into your crmURL token is: wp-admin/admin.php The remainder of your checksum link seems to line up as it should.

Could you please verify (and report back as an Edit in your question):

  1. What is listed for your Old and New Base URL on Administer > System Settings > Cleanup Caches and Update Paths?\
  2. What your Base URL is listed as in your civicrm.settings.php file?

Per the Wordpress install instructions, Step 6, the civicrm.settings.php file is located here: <wordpress>/wp-content/plugins/civicrm/civicrm.settings.php

The relevant line will have something akin to: define( 'CIVICRM_UF_BASEURL' , 'https://lofcenter.org/');

1

I'm going to mark this as answered/fix because the latest batch of reminders did work. The link sent with the Pledge Payment reminder works as of today, here's a copy of the link that the crmURL shows, for an unknown reason it does not have the extra wp-admin/admin.php bit.

https://lofcenter.org/CiviCRM/?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=1&cid=3305&pledgeId=5&cs=c8321de782a6e8fb19ce9305f9a2ffe4_1452834091_336

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.