3

When running the Geocoding/parsing scheduled job (CiviCRM 4.6.10/Drupal 7) I get the following error message:

    Full message: 
Finished execution of Geocode and Parse Addresses with result: Failure, Error message: Error: Both Geocode mapping as well as Street Address Parsing are disabled. You must configure one or both options to use this script.

I've got Google set as the service provider for mapping and geocoding data, with no API key. I'm not interested in address parsing, and have the parsing parameter for the scheduled job set to 0.

If I run the job via URL it works fine, but executing it via the UI gives the error message.

Am I missing something?

4

It looks like you have may not have set a command parameter in the Scheduled Job (but maybe you're adding it when you run the job via URL?). Do you have geocoding=1 in your command parameters for "Geocode and Parse Addresses"?

See Managing Scheduled Jobs from the Civi wiki for reference (2nd row of the table).

  • 2
    Thanks Allen - you made me look again at what I had set for the parameters in the UI. By default they look like "geocoding=[1]" and "parse=[1]". I had edited the digits to suit but left the square brackets in place. Removing the square brackets is required for the job to run correctly. – Graham Dec 31 '15 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.