3

I've upgraded from 4.4 to 4.6.10 on Drupal 7.41. I'm getting the following issue when attempting to make a contribution:

We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site adminstrator for assistance.
Site Administrators: This error may indicate that users are accessing this page using a domain or URL other than the configured Base URL. EXAMPLE: ...

Error type: Could not find a valid session key.

I didn't have this problem before updating to 4.6.10.

I have cookies enabled.

I have confirmed that the Civi and Drupal base URLs are the same and match what is in the address bar of my browser.

Drupal caching is currently disabled.

I have a user 0 in my Drupal database.

Finally and this is the weird thing, when I get the error if I click the back button and resubmit the form it works fine.

Does anyone have a solution or work around for this problem?

Updates

Turns out while the message references sessions it has to do with the contribution page losing the ID but it's an issue with the payment plugin.

1

Turns out while the error message is about the session key the issue is with the stripe payment processor plug-in. I'll raise the issue on the plug-in's issue queue.

| improve this answer | |
1

I had the same issue, with a slightly different solution. After days of searching I found that my Drupal/civicrm settings.php file had several values altering the default settings for PHP and the way cookies were handled.

After commenting out these cookies settings, civicrm was able to handle the cookies properly. Voilà, system started working properly.

ini_set('arg_separator.output',     '&');
ini_set('magic_quotes_runtime',     0);
ini_set('magic_quotes_sybase',      0);
ini_set('session.cache_expire',     200000);
ini_set('session.cache_limiter',    'none');
ini_set('session.cookie_lifetime',  2000000);
ini_set('session.gc_maxlifetime',   200000);
ini_set('session.save_handler',     'user');
ini_set('session.use_cookies',      1);
ini_set('session.use_only_cookies', 1);
ini_set('session.use_trans_sid',    0);
ini_set('url_rewriter.tags',        '');

Hope this helps someone :)

| improve this answer | |
  • Can you please be more specific on how you solves the problem? – Sonicthoughts Feb 3 '16 at 5:16
  • Sorry, hopefully this is a little clearer. – fyberoptik Feb 3 '16 at 10:54
  • While the error message I received from CiviCRM mentions the session, it actually has to do with loosing the ID of the contribution. – DaveBagler Feb 10 '16 at 1:53
0

I cannot comment (rep), but I will edit this post later:

Can you provide more info:

  • Is it a Contribution page or Event regi?
  • 1-time contribution or recurring?
  • Memberships, or other features enabled?
  • Any other extensions enabled?
  • Any errors in the browser JS console?
  • Any browser extensions that might get in the way (Ghostery / ABP)?
  • What version of Stripe API (in your stripe.com dashboard)?
| improve this answer | |
  • Sorry drastik, I've been busy with other projects but will update the Github issue soon. Basically I found a work around by using the latest commit of webhook.php and an older commit for the rest of the module. – DaveBagler Feb 10 '16 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.