3

Using: Joomla 3.4.7; CiviCRM 4.6.10; testing with Chrome, Firefox, Safari, and devices (iPhone, iPad, Android)

ISSUE: Contribution Form (infrequently) fails; bounces to Home Page (if one can get to next screen/action button) or timeout error (on devices, when one chooses PayPal option)

  1. Using our Contribution form USUALLY SUCCEEDS, and for both the PayPal and Credit Card options
  2. INFREQUENTLY it fails; always at the point when User touches/selects the lower Payment options fields
  3. This problem cropped up earlier this year and it was more pervasive; using forum info and our own testing we isolated that the use of "OTHER Amount/custom field" apparently triggered the problem. We took two steps: Updated to the latest CiviCRM, and removed the "OTHER Amount" option.
  4. This gave us SUCCESS; Robust cache deletion was required for some to see this success, though.
  5. Subsequent testing on multiple platforms/browsers/devices made us think this was resolved, and we had planned to revisit the OTHER issue in January.
  6. HOWEVER: The problem showed up again yesterday for ONE User (out of almost forty successful submissions). That one user confirms that the problem exists on Safari and Chrome (Mac), and on an iPhone.
  7. As a result of his failure, we re-tested: we had success on everything except an iPad—when we got to the form fields related to payments, it bounced us to the Home page; when we noodled with the fields (tabbed instead of touched) we could fill out those fields but it took us to the home AND reported a timeout.

Any and all input would be greatly appreciated. Thanks in advance for your considerations.

  • We are would be willing to pay someone to fix this for us. Rather desperate for an answer. – Greg Correll Feb 15 '16 at 17:44
  • We have isolated this (we think) to JUST devices (iPads/iPhones). An identical CiviContribute form on another client site, on the same Rochen server, does not have this problem. So this should enable smart, thorough folks like us to isolate the problem, right? Well, our seemingly endless investigation of this has yielded tons of minutiae, but no fix or smoking gun. We've got a dupe of the Live site set up, and conduct dozens of three way tests between Live, Dev, and Other (Client site form that works). – Greg Correll Feb 24 '16 at 15:38
  • We're thinking there might be something corrupted about this Civiinstall (tho no probs with recent Civi upgrade). Confirming/fixing that, if true, is above our pay grade. We tried loading the form in Protostar template with no modules etc on (very few on as it is). No joy, same problem. here's the latest error: !Valid XHTML – Greg Correll Feb 24 '16 at 15:48
  • Any Joomla (or CiviCRM) extensions installed on the problem site that aren't installed on the working site? Just spitballing. – Laryn - CEDC.org Feb 24 '16 at 16:20
  • Thanks Laryn. No CiviExtensions difference. No meaningful diff on J extensions that we can see. Neither use excessive addons; prob site has Docman et al, good site does not. Prob site uses NoNumber's Adv Mod Mnger, good site does not. Testing that now... – Greg Correll Feb 24 '16 at 16:49
0

It seems as if the problem requires a proper technical analysis by someone who prvides professional CiviCRM support. You mentioned in another post, that no service provider responded to your enquiries - I am sorry for that, it is not usually that way.

Feel free to approach the CiviCRM partners - including us (SYSTOPIA).

  • Hi Andrew We tested w diff themes, and in every respect, and never got it to work. Tried it on new install; same probs. We have stepped away from Civi and replaced it on all but one client site, and will be replacing it on the last one this year. As longterm users of Civi we are keenly disappointed with this and other bugs, and how unresponsive and un-useful the forums have become. We have to solve problems, not install them and watch them plague our clients. Perhaps Civi is indifferent to Joomla now? Dunno – Greg Correll Dec 5 '16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.