0

I am running Joomla 3.4.7 and CiviCRM 4.6.9. I am getting the following error when my cron runs automatically.

--2016-01-05 08:00:01--  http://www.sitename.org/administrator/components/com_civicrm/civicrm/bin/cron.php?name=loginid&pass=password&key=c12121212121212121212121
Resolving www.sitename.org... 188.143.132.180 Connecting to www.sitename.org|188.143.132.180|:80... connected.
HTTP request sent, awaiting response... 500 Internal Server Error
2016-01-05 08:00:01 ERROR 500: Internal Server Error.

If I run the cron manually, I get the following 500 Server Error:

The website encountered an error while retrieving http://www.divingrebels.org/administrator/components/com_civicrm/civicrm/bin/cron.php?name=loginid&pass=password&key=c121121212121212121212121. It may be down for maintenance or configured incorrectly.

The cron which is running in CPanel is a wget cron.

I contacted my webhost and they sent me the log which shows the cron running, but the email I get after the cron runs shows the 500 Server Error. I have a 100 emails per hour limit and have the mailer batch limit in CiviCRM set to 99.

I have enabled debugging and backtrace in CiviCRM, but have no idea where to find the info or how to read it. Any help would be greatly appreciated.

  • What exactly was the 500 Server Error as shown in the log files? – Catorghans Jan 5 '16 at 14:56
  • There is no error in the log file which my webhost sent. According to the server logs, the cron command is working fine, please see below: ### Jan 4 21:00:01 server19 CROND[586069]: (divingr) CMD (wget 'sitename.org/administrator/components/com_civicrm/civicrm/bin/…' >/dev/null 2>&1) Jan 4 22:00:01 server19 CROND[1011811]: (divingr) CMD (wget 'sitename.org/administrator/components/com_civicrm/civicrm/bin/…' >/dev/null 2>&1) – undrwatrdan Jan 5 '16 at 15:44
  • However, the email I get after the cron runs shows the 500 server error --2016-01-05 09:45:01-- sitename.org/administrator/components/com_civicrm/civicrm/bin/… Resolving www.divingrebels.org... 198.143.132.130 Connecting to www.divingrebels.org|198.143.132.130|:80... connected. HTTP request sent, awaiting response... 500 Internal Server Error 2016-01-05 09:45:02 ERROR 500: Internal Server Error. – undrwatrdan Jan 5 '16 at 15:49
  • ok, those seem access logs and not error logs. If the webhost could give an error log, that would help. Can you check if you can find an error in the CiviCRM log file? That should for Joomla be in a file in <joomla-root>/media/civicrm//civicrm/ConfigAndLog/ – Catorghans Jan 5 '16 at 16:00
  • I will ask the webhost for an error log. The latest log file I find in the path you provided is 12/20/2015 which is before this issue started occurring. – undrwatrdan Jan 5 '16 at 16:07
3

I ran an update to Joomla 3.4.8 and it resolved the issue. There must have been a bug in Joomla 3.4.7 which caused the cron issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.