0

There is a problem with the Civi Reports. The report feature is not pulling all of the members in each of the categories, when we generate one member report and also generate the same report with the same criteria on advance search but there is difference in the both result. Please check the screenshot.

Ultimately there is a bug somewhere in the reporting feature that is preventing all of the records from showing up when they are queried.

Please let me know is anyone faced such type of issue, if yes then please suggest solution. Looking forward for response on same.Advance thanks to all.

  • 2
    there's not enough information here to give an answer. Can you please give a) the name of the report, and b) your CiviCRM version? From here, it looks like you're using the "Contribution Membership Report" and comparing it to a contact search. If so, your search will turn up people with completed non-membership contributions; the report will only turn up people with completed contributions tied to the memberships. Please look at one of the contacts who appears in the search but not the report and let us know if that's the case. – Jon G - Megaphone Tech Jan 7 '16 at 15:12
1

I do see a difference in the search criteria. Not sure if it has an impact on the results.

In the report it looks you also limit on "Group : Rasta Winter Memberships". Would that cause the difference in outcome?

  • thanks Catorghans, we tried your suggestion but not succeed. In both sections report -difference still there.Please see these screenshot:1. member report screenshot (dowce.com/~FjG) 2. advance search screenshot (dowce.com/~Fj1). – Karamveer Jan 7 '16 at 13:21
  • any update on this issue? – Karamveer Jan 14 '16 at 10:35
  • @Karamveer - You're asking for an update on the issue, but haven't responded to my comment, which is very likely to contain the answer. If you respond, someone can probably help you. – Jon G - Megaphone Tech Feb 6 '16 at 16:20
  • @JonG Thank-You and Sorry for delay I just saw your messages now. Please see below inline my comments and let me know what you suggest.Also for better explanation I am sharing some attached screenshot, hope that make sense more. a) the name of the report: I created myself a custom report with some fitters (Membership types, contribution status) and same filter applied on Advance search form. When I use the Advanced Search option in Civi and use the same filters as I used in the reports it provides me with all 14 records which you can see in the attached screenshot /*REST IN NEXT COMMENTS*/ – Karamveer Feb 12 '16 at 6:55
  • @JonG b) Your CiviCRM version? : Drupal-Civi-Version-4.6.10 From here, it looks like you're using the .. Comments:On Custom report I filtered records on the Membership group with contribution status as completed. I further applied some filter changes on Adv. Search like contribution status but in all cases reports not matched. Please let me know why report of Adv. Search not matched with Custom reports. – Karamveer Feb 12 '16 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.