1

I've got a site using CiviCRM 4.5.8

I've tried to enable detailed change logging in Misc (Undelete, PDFs, Limits, Logging, Captcha, etc.)

But the change log tab still shows the basic changed by person x on date y details.

On other sites I've worked with (4.5 and 4.6) enabling detailed logging changes the log view automatically.

Is there a related setting I've overlooked?

Should I just bite the bullet and upgrade the site?

Cheers

Craig

  • 1
    Version 4.5.x doesn't get security updates, so if you don't bite the bullet, it's going to bite you! – Coleman Jan 11 '16 at 17:11
  • What CMS version are you using? – Allen Hutchison Jan 11 '16 at 17:48
  • I'm having similar problem. Did anybody find a suitable solution for this problem? I'm running on 4.6 and have admin rights. Any help will be great – Pee Sep 6 '17 at 13:50
  • Pee - we are running 4.6.25 as well as 4.7.19 and the steps below solved it on both – Catherine Oct 25 '17 at 13:46
2

I had the same problem - we run four different civi instances. Two had detailed change logs, two did not.

Across all instances users had same privileges and all four instances had logging enabled. The difference other than civi versions was that two had change log report. So the change log tab runs off reports. Steps to fix:

1) check logging enabled in Misc (Undelete, PDFs, Limits, Logging, Captcha, etc)

2) in Admin > CiviReport > Manage Templates.. check the summary and detailed contact logging templates are enabled (as default they were disabled on ours)

3) The MISSING bit... create an actual Contact Logging Report (Summary) from the template.

and that did the trick.

Note: when creating the report clicking 'refresh results' the report failed to load the results - i guess its too large. But save the report anyway and the detailed changes are displayed on the contact record.

Also it does not seem to need the detailed contact change report created only the summary.

Here the documentation that pointed us in the direction of reports to fix the problem https://docs.civicrm.org/sysadmin/en/latest/setup/logging/

The above worked against: v4.6.22 v4.6.4 v4.6.8 v4.7.20

1

It sounds like you may not have the proper MySQL privileges. I'll admit I'm a little hazy on exactly what privileges are necessary with which SQL version - but having the SUPER and CREATE TRIGGER permissions together works on any Civi-supported version of MySQL. You may be able to skip SUPER in later versions (MySQL 5.5+?).

If you're not sure, log into MySQL as the Civi user and run SHOW GRANTS and report back with that, plus the version of MySQL.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.