2

Am in the process of switching from Paypal to Stripe. (Joomla 3.4.8 & CiviCRM 4.6.10).

Everything appears to be correctly configured but something must be wrong as on clicking confirm contribution I get a reply:

Error Oops! Looks like there was an error. Payment Response: 
Type: 
Code: 
Message: 

Which is blank. When I check Stripe's log I can see that my info was received and then something returned:

Parsed Request POST Body:
key: "pk_live_[trimmed]"
payment_user_agent: "stripe.js/b3b3690"
card:
name: "[trimmed]"
address_zip: "HA3"
number: "***************"
cvc: "***"
exp_month: "11"
exp_year: "2018"

Response body:
id: tok_17SA6RHq4Z0Eyf9xt0WKzQvv
object: "token"
card:
id: card_[trimmed]
object: "card"
address_city: null
address_country: null
address_line1: null
address_line1_check: null
address_line2: null
address_state: null
address_zip: "HA3"
address_zip_check: "unchecked"
brand: "Visa"
country: "GB"
cvc_check: "unchecked"
dynamic_last4: null
exp_month: 11
exp_year: 2018
funding: "debit"
last4: "****"
metadata:
name: "[my name]"
tokenization_method: null
client_ip: "92.10.229.3"
created: 1452535755
livemode: true
type: "card"
used: false

The only thing I can think that's wrong is the webhook address for Stripe as this page suggests the path is different to the plugin's instructions: https://forum.civicrm.org/index.php?topic=27531.0

I've tried with the URL specified in the plugin instructions: /index.php/component/civicrm/?task=civicrm/stripe/webhook as well as /media/civicrm/custom_ext/com.drastikbydesign.stripe-1.9.1/packages/stripe-php/lib/stripe.php /media/civicrm/custom_ext/com.drastikbydesign.stripe-1.9.1/templates/CRM/Stripe/Page/Webhook.tpl but nothings works. (I'm using full paths but can't paste them into Stackoverflow without more reputation)

Any help really appreciated.

Nic

1

Per our conversation, my current guess is a recent API change on Stripe's end is causing your issue.

My test install still works, but my API version is set to 2014-10-07.

Here is the CHANGELOG from my working version: https://stripe.com/docs/upgrades?since=2014-10-07#api-changelog

1

It turned out the server lacked PHP Open SSL. This wasn't being logged immediately as an error, but Andy Walker managed to get the logs to print the following and once installed everything worked as intended (after the Javascript cache was cleared).

Could not connect to Stripe (https://api.stripe.com).  Please check your internet connection and try again.  If this problem persists, you should check Stripe's service status at https://twitter.com/stripestatus. Reason was: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.