2

I recently upgraded from 4.4 to 4.6 using Drupal 7 and since then I have had some major performance problems (Search Builder responds to everything with a Timeout now.) Even simple queries for users in a group will often timeout. Before the upgrade I had no problems. Has anyone else run into performance problems with 4.6.10? Any suggestions?

Updates

  • Searches were fine before the update
  • I am using smart groups
  • During or since the upgrade, have you deleted the contents of your temp_c folder and cleared cache for CiviCRM? – Allen Hutchison Jan 11 '16 at 20:45
  • Yeah before I upgraded, and again since I've upgraded. – DaveBagler Jan 11 '16 at 21:03
2

You may be running into performance issues if you have groups in your Search Builder queries. See CRM-16483.

  • I'm not sure that's what I'm running into, but I think it's likely. Thanks for the point in right direction. – DaveBagler Jan 12 '16 at 15:48
1

Do you have the problem with the search builder interface that is too slow or after you search to get the result?

How is the advanced search behaving?

The problem is that it's hard to find what the root cause of the problem, as it's likely dependent of your configuration and how you are using civicrm.

One thing you can do is log the slow queries (it's a configuration option in mysql) that takes more than a second. It's not going to solve the problem, but at least might help you to identify the problem

And a wild guess: do you have smart groups? These can have a massive impact on performance. ACL might be another reason that it's slow.

EDIT: more suggestions now that you confirmed smart groups

You might want to cache the smart groups for a longer period of time (say 2 hours) Administer > Customize Data and Screens > Search Preferences

and enable the cronjob to re-build the smart groups cache every hour

As for the general speed, it's likely that you need more resources to run civicrm 4.6 compare to 4.4, if your server was already borderline too weak to handle 4.4, the new features introduced by 4.6 might be the extra nudge needed to make it trip over. It might be worthwhile investing a bit more on your hosting.

  • The interface is fine (just as bad as it was in 4.4) it's that it times out before returning results. Occasionally when only searing for contacts who are in a smart group. I realize that smart groups are slow, but with the same configuration it was working in 4.4, that's why I'm wondering if something changed between 4.4 and 4.6.10 that would impact the performance of Search Builder. – DaveBagler Jan 12 '16 at 15:46
  • Advanced search is also far slower than it used to be. – DaveBagler Jan 12 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.