5

CiviCRM 4.6.2 on WordPress 4.2.1 When I'm logged into CiviCRM as an admin user, I cannot register for an event. I get a page with multiple sections, some with Private: Event Name, others are just Event Name without the Private on the front.

Log out, click the Event Registration and everything loads beautifully with all the fields showing up correctly.

BTW: Upgraded to CiviCRM 4.6.6 and WP 4.6.6 since then, same issue. As an aside note, my dev site doesn't have this issue. So it's something very particular to this one install.

Update: My dev site exhibits the same behavior when a Post is created with CiviCRM embedded and marked as Private, as the the Answer points towards.

  • Tested this on the 4.6 WP Demo page, and it works correctly. So, either this is a bug resulting from upgrading, or a misconfiguration on our site. Anyone else experiencing this issue? – G H May 7 '15 at 14:39
  • Looking at the Demo site again, they have a column called CiviCRM Administrator that I don't have. How? Why? Can I add it? Should I? How? – G H Aug 7 '15 at 19:35
  • Ok, so this is bigger than just Events. I can't see anything on the "Public" side of CiviCRM when I am logged in to CiviCRM. I can see "Public" Wordpress content, but not "Public" CiviCRM content. Me thinks me goofed up somewheres! – G H Aug 7 '15 at 19:48
  • GH it sounds like you are missing some Permissions and or a User Role (is that the correct WP terminology). If you take a look at demo here wp46.demo.civicrm.org/wp-admin/… you might get some insights. Sorry I don't know WP well enough to know how you might have broken things. But my guess is your user does not have the CiviCRM Administrator 'role' – petednz - fuzion Aug 10 '15 at 20:28
  • also suggest you edit your Title and Question since this is way different to the original. – petednz - fuzion Aug 10 '15 at 20:28
4

Also need permissions for Profile View and Profile Create? That solved a similar problem in my case

  • Nope. Both have full access all the way across. Next idea? How about CiviCRM: view my contact and CiviCRM: edit my contact? Both are totally unchecked. That seems wrong to my pea sized brain. – G H Jul 10 '15 at 13:52
  • Forget that. Same setup on the Demo site. All the other perms look the same as on the demo site as well. – G H Jul 10 '15 at 18:18
3

You should maybe check your permissions. I work with Drupal but I think that Wordpress has recently updated to be the same.

There are two permissions that allow you to see the event info and registration pages:

CiviEvent: view event info CiviEvent: register for events

They might just be checked for the public by not for administrators.

  • Good thought, but nope. Check boxes checked all the way across. I unchecked, rechecked, and saved, just to be sure. Other ideas? – G H May 1 '15 at 12:42
  • Check Lionel's answer. Currently the 'Profile Create' permission is also required, because contact information is being created via the profile embedded in the registration form. – John Jul 10 '15 at 13:06
2

Wow! That was painful! I had set up a couple of test posts for Cases, and marked them as private in Wordpress. I deleted those posts and now everything seems to be working once again as expected. (I left the one post that is a Public post. Note: These are posts, not pages.) Creating a new Private Post with a CiviCRM tag embedded resulted in the same behavior. I'll have to do some more testing, but it would seem that you can't have Private Posts with Civi content and see Public content while logged in. Thanks to everyone for your suggestions! I guess I'll try to figure out how to word such a bug now. Wish I knew how to just go fix it.

EVEN BETTER! It's already fixed. Or actually this is a symptom of a misconfiguration. (Potentially due to upgrading over time and missing a change.) By setting the WordPress Base Page variable to a newly created page, the problem disappeared. See the comments on the filed bug linked in the comment below in order to see what Christian Wach correctly surmised, along with how to actually fix it.

1

did you ensure that you are indeed an Admin? When you set up your WP User login, whatever you put in for your email will be the 'key' for your Civi Contact/User record. Find your contact record in Search and ensure that you're a member of Admin group. There's a function to 'sync' WP and Civi user records, Administer/Users and Permissions too. But frankly it sounds like something else is awry, not just permissions. Can you turn on Firebug, compare w/your dev site? Is this install running on the same server as your dev site, and if not, is the setup the same?

  • Well, no, but no. So, I'm not added to the Civi Admin group, but I am an Admin in WordPress. Since these are public pages, it shouldn't matter either way. (Using wpDirAuth plugin for getting users from LDAP dir.) This is the same on both live and dev machines, both are VM's with extremely similar setups. (Finding diffs between machines will be difficult.) However, the dev machine works as expected, but not the live one. Syncing users doesn't fix or change anything. I'll go check Firebug again and see what I find, but I don't think I found anything helpful when I looked the other day. TNX – G H Aug 10 '15 at 17:28
  • Just cause it was easy, I manually added myself to the Civi Admin group, and it made no difference. GRRRR. – G H Aug 10 '15 at 17:34
  • HA! The only one showing an error is the one that's working. And it's just an L10n cache error, which doesn't seem related or important. It also looks like it goes and regenerates it when it doesn't find it. Is there some setting in WordPress that can make CiviCRM only viewable by certain user groups? It seems like we originally had to be an Admin in WP to do anything with Civi, and then the ACL stuff got added later. (Yes, I've cleared the Civi cache.) – G H Aug 10 '15 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.