4

I have set up a donation page linked to Paypal. (https://contacts.network211.com/civicrm/contribute/transact?reset=1&id=6)

  • When I attempt to use the contribution form as a non-logged in user, I enter my donation amount and email address. When I hit Confirm Contribution, the system returns to the contribution form with all fields empty. No error message or indication of what is going on.
  • The contribution works if I am logged into civi as an authenticated user.

Settings

  • I am not asking the user for any additional information, ie. not using a profile
  • The form is set as active/online
  • Under drupal permissions, I have CiviContribute: make online contributions selected
  • I have looked in both Drupal and Civi logs and don't see anything that seems to point to the problem.

This is very frustrating!

(I asked the same question earlier with no resolution. How to allow contributions from non-members This link also yields no answers Why can't anonymous users make contributions?)

  • Do you have any extensions installed? If you disable them one at a time to test, might that help? – Allen Hutchison Jan 15 '16 at 17:56
  • Maybe it's something about your base url or resource url's is not set up quite right. Also, do you have clean url set on the drupal side (contacts.network211.com/admin/config/search/clean-urls)? I believe you should be able to replace the ? with a / in your link and have it still work, i.e. ...civicrm/contribute/transact/reset=1&id=6) . It doesn't in your case. (It does in my implimenation if clean url's are set. If they're not set I get errors on the paypal site.) – Paul-Tahoe Jan 15 '16 at 18:05
  • @Paul-Tahoe: I'll try this, but it doesn't make sense in that civi never takes me to the confirm page (which is still on civi) – Keith Sorbo Jan 15 '16 at 19:30
  • @AllenHutchison: I have no extension installed or at least none are checked under Civi in the drupal modules page – Keith Sorbo Jan 15 '16 at 19:32
  • @KeithSorbo, for Civi specific extensions, you would want to look in your CiviCRM menu: Administer > System Settings > Manage Extensions and see if any extensions are enabled there. – Allen Hutchison Jan 15 '16 at 19:34
3

Further investigation on my site, which was exhibiting the same issue as that noted by Keith Sorbo, showed that there was no 'user 0' record in the Drupal users table.

This page - https://www.drupal.org/node/1029506 - offers various options about how to reinstate a 'user 0' record in the Drupal database.

Once I had a 'user 0' record the CiviCRM contribution page worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.