1

I'm running Wordpress 4.4.1 and CiviCRM 4.6.11

The main page of our site http://www.mltawa.asn.au is redirecting to an old event's page (http://mltawa.asn.au/2015-agm-registration/?page=CiviCRM&q=civicrm/event/info&reset=1&id=7). When I disable the event, it goes into a loop or, if logged in as admin, I get the pop-up message in the back-end:

The event you requested is currently unavailable (contact the site administrator for assistance).

Ideas of where to start looking to fix this? :)

  • Can you go to Administer - System Settings - CMS Database Integration and tell what's in "WordPress Base Page"? – Catorghans Jan 17 '16 at 8:37
  • Ya, it's just set to the default - it's blank atm. – Esther Jan 17 '16 at 9:00
  • so, nothing in the text field? – Catorghans Jan 17 '16 at 9:00
  • That's correct. Sometimes I get this error "Exception thrown GAPI: Failed to authenticate user. Error: "developers.google.com/accounts/docs/AuthForInstalledApps " I don't know where to start looking... – Esther Jan 17 '16 at 9:02
  • If I deactivate the CiviCRM plugin, it's all fine, so I know there's some box somewhere I need to tick or untick or change! – Esther Jan 17 '16 at 9:03
1

Create an empty Wordpress page, name it what you want, for example "civi". Add that name to the "WordPress Base Page" in Administer - System Settings - CMS Database Integration.

For more info see: http://wiki.civicrm.org/confluence/display/CRMDOC/Displaying+Public+Forms+in+WordPress+Frontend+Sites

Does that work?

  • Unfortunately not :( – Esther Jan 17 '16 at 9:15
  • hmm, what happens if you go mltawa.asn.au/2015-agm-registration Does that page exist also when CiviCRM is disabled? – Catorghans Jan 17 '16 at 9:21
  • Yes - the page exists, and then just displays the header image and shortcode for the form. – Esther Jan 17 '16 at 9:36
  • Another thing I can think about is something weird in Wordpress Settings - Reading - Front Page settings. – Catorghans Jan 17 '16 at 9:37
  • 1
    I see the "normal" front page now, it seems like [civicrm component=”event” id=”7″ action=”register” mode=”live” hijack=”0″] is somehow taking over command and forwards to the page. What happens if you delete this component from that page when you activate CiviCRM? – Catorghans Jan 17 '16 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.