I have many contacts with no first name, last name, or email. I don't know what my client has done to this site.

fist name and last name can empty

I viewed the records and they contain only id and sub-contact type.

enter image description here

Edit: I also tried the suggestion by Heather O. and looked at the Change Log.

I added one contribution where the external id there is not in my system but no new records have been created.

Do you have any idea?

  • Either first_name or last_name or email is required. I have no idea how the empty ones get in there, perhaps they have switched off some dedupe rules? Commented Apr 30, 2015 at 8:53
  • From there I'd personally then look at the change log to see if I can identify something that was happening when the records were added. Were they all added at the same time? Sounds like an import. Were they added a different random times? Sounds like you might have an unsecured form that spam is trying to get through. Check your spam prevention modules and see if you can identify anything. Not sure of your CMS but we run Drupal and use Mollom and Honeypot on our sites.
    – Heather O.
    Commented May 1, 2015 at 12:27
  • You might want to blur out the text to the left of the ID number in your second screenshot Commented May 1, 2015 at 22:00
  • thankyou for your explanation i will check it, and get back to post the result best regards Commented May 2, 2015 at 5:37
  • hi Heather , yes, all of the empty contact is imported at the same time. so , what should i do ? Commented May 4, 2015 at 9:11

4 Answers 4


I'd recommend clicking on one of the records and seeing what information is there. Presumably there is something, custom data or an activity or relationship.

I have seen this happen on imports that haven't been thought through. So for example, if you're using an external id to match contacts records on an activity import and there isn't a matching external id in CiviCRM, a new records will be created with only the external id on and activity.


I get this using import contacts to update contacts, usually to update addresses after we get back the results from NCOA. As far as I can tell it created the contact record and nothing else. They aren't connected to anything. My suspicion is the file has both households and individuals in it, so I run it twice since even for update you have to specify individual or household. I just tried it and, of course, didn't duplicate the issue.


thanks to all,

i have found , the cause is : i try to update contacts via import ( update ), with the contacts data i will import only have external identifier.

actually we can import contact by update ( contact -> import contact -> select update ) which do not have first name and last name.

regards, henro


I had that kind of problem when synchronising contacts with users (CiviCRM/Drupal). Some user accounts seems to be wrecked and it generated empty contacts.

  • hi matthias how do i know that user account is wrecked ? Commented May 4, 2015 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.