Suddenly a filter on Contact ID is unexpectedly appeared on my "Constituent Detail" report. Since Contact ID is not one of the fields enabled for filtering, I cannot remove it. So, every time I want to use the report, the filter is automatically set and I cannot use the report.

Any suggestion?


Note: This issue has been reported at: https://issues.civicrm.org/jira/browse/CRM-17872

  • is same happening on the demo site?
    – petednz - fuzion
    Jan 18, 2016 at 21:30
  • Hi Allen, what do you mean with "demo site"?
    – marcello
    Jan 19, 2016 at 6:46
  • 1
    Pete is suggesting that you try to do the same thing on the CiviCRM demo site to see if the problem is with CiviCRM generally or specific to your set up. You can access the demo sites at: civicrm.org/demo choose the same version as the CMS you are using (e.g. Drupal, Joomla or WordPress). Jan 19, 2016 at 9:47
  • It would also be helpful if you edit your question to include your CMS (Drupal, Joomla or WordPress) and the version of CiviCRM you are using. Jan 19, 2016 at 9:48
  • Sorry William, I'm using Drupal and CiviCRM version 4,6,11. The problem is only on my own site. Until yesterday all was working fine. Now somewhere, I suppose in the database, the filter is wrongly "remembered" and I am not able to delete it. I've already cleared Drupal cache without effect.
    – marcello
    Jan 19, 2016 at 11:11

3 Answers 3


The same thing happened to me. The Constituent Detail report is called from the Constituent Summary Report. I ran the summary report and clicked on a contact to go to the detail report. As an Administrator I accidentally updated the Constituent Detail Report. It must have saved the contact ID used in the call from the summary report. Every time I tried to use or call the detail report from then on it used the stored (saved) contact ID.

To solve the problem I deleted the Constituent Detail Report from the Contact Report area. I then created a new report using the standard Constituent Detail Report as the basis.

  • Ron - are you able to recreate the problem either on your site or the demo? Jan 24, 2016 at 17:49
  • Yes, I just recreated the issue on the CiviCRM Demo site for WordPress. I was also able to apply the fix. I deleted the problem report then recreated it and all worked fine. Jan 24, 2016 at 20:55
  • Interesting - initially I wasn't able to replicate the issue for Contributions, but checking the contact name column and clicking on a name takes you to the detail report - which when saved causes the problem. I think this is a bug, please create an issue issues.civicrm.org (or let me know if you'd like me to do it). Jan 24, 2016 at 21:21
  • Sanjay, I am new to the CiviCRM community. It would be better if you create the issue so It is done in the proper place and in the proper way in order for it to get prioritized and correct. Jan 24, 2016 at 22:53
  • Welcome to the community Ron. Thanks for working on replicating the problem. I've created a ticket issues.civicrm.org/jira/browse/CRM-17872 - You needn't be timid in creating tickets your self, although it's worth doing a search to see it hasn't already been reported. Jan 25, 2016 at 15:26

I have recently seen the same thing with the Contribution Detail report.

As Ron also suggested this was fixed by recreating the report using the report template. Reports > All Reports > New Report > Contribution Detail Report

This seems to be a recurring problem as described starting 2010: https://forum.civicrm.org/index.php?topic=16905.0


I solved the problem going in the table "civicrm_report_instance" the column "form_values" had the filter recorded in. Properly editing the field value, the filter was removed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.