2

The unsubscribe via email does not use the correct email address. I have "myname"@gmail.com but when I send a test it adds this strange email address u.77.3.61020d9ae6a273d5@gmail.com as the email address.

2

in order to use civimail, you need to have your own domain name for to manage the bounces, and it's the same address used for the unsubscribe (it adds to the address that weird u.xxx string that you see to be able to distinguish between your contacts who is actually unsubscribing or bouncing, it's called VERP).

It doesn't use any of your "normal" mailboxes, it needs a dedicated one to handle automatically bounces and unsubscribe.

For what I see, you haven't properly set-up your email account in civimail and use a gmail address (and didn't fill the local part)

http://book.civicrm.org/user/advanced-configuration/email-system-configuration/

0

It sounds like you haven't set up your email system correctly. This is the sub-address part of the email but it is missing the local part.

Go to Administer > CiviMail > Mail accounts and set 'local part' to be 'myname+'.

See the manual for more details: Email system configuration

  • 2
    looks like we answered at the same time ;) to add to your answer: it won't work using a gmail address (because the SPF doesn't allow the civi server, or because using gmail smtp is not an option for any "proper" mailing – Xavier Jan 20 '16 at 8:59
  • Thank you both so much for your help. I am doing this on a local server and did not expect the bounces to work. I made a workaround for the unsubscribe by putting a mailto in my footer and "cheekily" whiting out the unsubscribe so i can use civimail.(Now I see that I can disable check for tokens) It seems that I have an issue with Civimail and Cron. Cron will not work and gives the message I cited but if I go to administer/system settings/scheduled jobs/send scheduled mailings and click Execute Now, it works. But it does not work if I go to Drupal and execute Cron now. – Hock Jan 20 '16 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.