I know there are some issues with how Wordpress sets page title. That being said, how can I change my current site title. All the pages I view have the title

CiviCRM ‹ civiCRM_test — Wordpress

I've been trying to figure out where this is set. It seems simple but grepping the file directory and searching the database for 'civiCRM_test' revealed nothing. I'm assuming the problem is that the title concats various strings all of which are too generic to find with a search. This is simple if you know where to look but I'm not sure where that is. Thanks

  • What is your site title in "Settings" --> "General"? Jan 22, 2016 at 13:41

1 Answer 1


CiviCRM content displays in WordPress in two separate ways. The first is through shortcodes: when you insert a CiviCRM shortcode in a page, CiviCRM renders the corresponding form.

CiviCRM still needs to render pages even if nobody has entered shortcodes for them, so the second method gives long URLs such as http://yoursite.org/civicrm?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=1 These URLs actually take the page that's before the question mark and replace all the content. It used to be (4.5.x and earlier) that this would be your site's home page by default, but now it defaults to a page titled "CiviCRM" with the slug civicrm.

I think this is what's generating the page title you're seeing: "CiviCRM" is the title of the base page, and "civiCRM_test — Wordpress" is your site name. Set the site name in your WordPress settings, and set the base page title by visiting the page you get when you edit the URL to remove the question mark and everything after it. Change the page title, and that should change it for all CiviCRM pages with the long URL style.

  • Nice catch. I was looking in the wrong database(the civicrm db) which is why my search yielded nothing. For anyone else, the value to change in your wordpress database is wordpress_db.wp_options where option_name='blogname' Jan 25, 2016 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.