3

This is a little embarrassing for me to ask, because years ago I set this up multiple times, however, I've been out of the CiviCRM world since 2012, and can't, for the life of me, figure out how to configure a CiviCRM 4.6 to send via sendgrid for an organization I volunteer with. I have a sendgrid account, I have CiviCRM 4.6.11 configured with wordpress.

Is there a special module/extension/plugin? custom script or code?

  • Did anyone figure this out? I get the same error message, using Sendgrid credentials, API credentials, all of the mentioned ports on their website. I've been in touch with Sendgrid support, but still not able to figure it out. Any insight would be helpful – Gilberto Lontro May 23 '17 at 15:48
3

Go to Administer> System Settings> Outbound Email (SMTP/Sendmail)

Select SMTP

server: smtp.sendgrid.net port: 587 authenticate: Yes Username: your sendgrid username password: your sendgrid password

  • Yossi, will that make sendgrid the sender for ALL mail? I must have a problem with my creds, because i tried that and got an error, I will try again. – Gregory Heller Jan 21 '16 at 23:13
  • Yes, that takes care of everything. What's the error? – Yossi Jan 21 '16 at 23:14
  • code Sending test email. FROM: info@s#######.org TO: info@s#######.com. Oops. Your SMTP settings are incorrect. No test mail has been sent. An error occurred when CiviCRM attempted to send an email (via SMTP). If you received this error after submitting on online contribution or event registration - the transaction was completed, but we were unable to send the email receipt. The mail library returned the following error message: Failed to connect to smtp.sendgrid.net:587 [SMTP: Failed to connect socket: Connection timed out (code: -1, response: )] – Gregory Heller Jan 21 '16 at 23:34
  • I've checked the creds, and used two different sets that i can log into the sendgrid account with no problem. – Gregory Heller Jan 21 '16 at 23:34
  • Have you sent it an email with this sendgrid account every from another platform? Are you sure your account is active? – Yossi Jan 21 '16 at 23:41
3

For anyone looking at this now if you are having issues with credentials that you think should not be blocked but are it is probably your firewall.

2

I had exactly the same problem: port 587 doesn't work for me either .. 2525 does

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.